summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-09 01:23:45 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-09 01:25:10 +0200
commitda99825c801829fc5199ae2819823d24ddbc106b (patch)
tree99ea2358b94c39624cb3c899210b6766dae4e1b7 /sys-libs/libcxx
parentsys-libs/libcxxabi: Use https for llvm.org (diff)
downloadgentoo-da99825c801829fc5199ae2819823d24ddbc106b.tar.gz
gentoo-da99825c801829fc5199ae2819823d24ddbc106b.tar.bz2
gentoo-da99825c801829fc5199ae2819823d24ddbc106b.zip
sys-libs/libcxx: Use https for llvm.org
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/libcxx-3.7.1.ebuild6
-rw-r--r--sys-libs/libcxx/libcxx-3.8.1.ebuild6
-rw-r--r--sys-libs/libcxx/libcxx-3.9.0.ebuild6
-rw-r--r--sys-libs/libcxx/libcxx-3.9.1.ebuild6
-rw-r--r--sys-libs/libcxx/libcxx-4.0.0.ebuild4
-rw-r--r--sys-libs/libcxx/libcxx-4.0.1.ebuild4
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild4
7 files changed, 18 insertions, 18 deletions
diff --git a/sys-libs/libcxx/libcxx-3.7.1.ebuild b/sys-libs/libcxx/libcxx-3.7.1.ebuild
index a608803e1f83..3535d3d94043 100644
--- a/sys-libs/libcxx/libcxx-3.7.1.ebuild
+++ b/sys-libs/libcxx/libcxx-3.7.1.ebuild
@@ -3,16 +3,16 @@
EAPI=5
-ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
+ESVN_REPO_URI="https://llvm.org/svn/llvm-project/libcxx/trunk"
[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
inherit ${SCM} flag-o-matic toolchain-funcs multilib multilib-minimal
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
+HOMEPAGE="https://libcxx.llvm.org/"
if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz"
+ SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz"
S="${WORKDIR}/${P}.src"
else
SRC_URI=""
diff --git a/sys-libs/libcxx/libcxx-3.8.1.ebuild b/sys-libs/libcxx/libcxx-3.8.1.ebuild
index 98b17e37d725..33c990ecd408 100644
--- a/sys-libs/libcxx/libcxx-3.8.1.ebuild
+++ b/sys-libs/libcxx/libcxx-3.8.1.ebuild
@@ -3,16 +3,16 @@
EAPI=5
-ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
+ESVN_REPO_URI="https://llvm.org/svn/llvm-project/libcxx/trunk"
[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
inherit ${SCM} flag-o-matic toolchain-funcs multilib multilib-minimal
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
+HOMEPAGE="https://libcxx.llvm.org/"
if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz"
+ SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz"
S="${WORKDIR}/${P}.src"
else
SRC_URI=""
diff --git a/sys-libs/libcxx/libcxx-3.9.0.ebuild b/sys-libs/libcxx/libcxx-3.9.0.ebuild
index d1d3852b1dae..185bbc3d7be0 100644
--- a/sys-libs/libcxx/libcxx-3.9.0.ebuild
+++ b/sys-libs/libcxx/libcxx-3.9.0.ebuild
@@ -6,7 +6,7 @@ EAPI=6
# Ninja provides better scalability and cleaner verbose output, and is used
# throughout all LLVM projects.
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-EGIT_REPO_URI="http://llvm.org/git/libcxx.git
+EGIT_REPO_URI="https://llvm.org/git/libcxx.git
https://github.com/llvm-mirror/libcxx.git"
PYTHON_COMPAT=( python2_7 )
@@ -15,9 +15,9 @@ PYTHON_COMPAT=( python2_7 )
inherit ${SCM} cmake-multilib python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
+HOMEPAGE="https://libcxx.llvm.org/"
if [[ ${PV} != 9999 ]] ; then
- SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz"
+ SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz"
S="${WORKDIR}/${P}.src"
else
SRC_URI=""
diff --git a/sys-libs/libcxx/libcxx-3.9.1.ebuild b/sys-libs/libcxx/libcxx-3.9.1.ebuild
index 8872bb9a6663..e847a9f5d318 100644
--- a/sys-libs/libcxx/libcxx-3.9.1.ebuild
+++ b/sys-libs/libcxx/libcxx-3.9.1.ebuild
@@ -6,7 +6,7 @@ EAPI=6
# Ninja provides better scalability and cleaner verbose output, and is used
# throughout all LLVM projects.
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-EGIT_REPO_URI="http://llvm.org/git/libcxx.git
+EGIT_REPO_URI="https://llvm.org/git/libcxx.git
https://github.com/llvm-mirror/libcxx.git"
PYTHON_COMPAT=( python2_7 )
@@ -15,9 +15,9 @@ PYTHON_COMPAT=( python2_7 )
inherit ${SCM} cmake-multilib python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
+HOMEPAGE="https://libcxx.llvm.org/"
if [[ ${PV} != 9999 ]] ; then
- SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz"
+ SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz"
S="${WORKDIR}/${P}.src"
else
SRC_URI=""
diff --git a/sys-libs/libcxx/libcxx-4.0.0.ebuild b/sys-libs/libcxx/libcxx-4.0.0.ebuild
index ce256df08e8f..43a14f9abb6b 100644
--- a/sys-libs/libcxx/libcxx-4.0.0.ebuild
+++ b/sys-libs/libcxx/libcxx-4.0.0.ebuild
@@ -13,8 +13,8 @@ PYTHON_COMPAT=( python2_7 )
inherit cmake-multilib llvm python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
-SRC_URI="http://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz"
+HOMEPAGE="https://libcxx.llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz"
LICENSE="|| ( UoI-NCSA MIT )"
SLOT="0"
diff --git a/sys-libs/libcxx/libcxx-4.0.1.ebuild b/sys-libs/libcxx/libcxx-4.0.1.ebuild
index ce256df08e8f..43a14f9abb6b 100644
--- a/sys-libs/libcxx/libcxx-4.0.1.ebuild
+++ b/sys-libs/libcxx/libcxx-4.0.1.ebuild
@@ -13,8 +13,8 @@ PYTHON_COMPAT=( python2_7 )
inherit cmake-multilib llvm python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
-SRC_URI="http://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz"
+HOMEPAGE="https://libcxx.llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz"
LICENSE="|| ( UoI-NCSA MIT )"
SLOT="0"
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 5787fb5be57e..3a1e5e5de31e 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -17,9 +17,9 @@ PYTHON_COMPAT=( python2_7 )
inherit ${SCM} cmake-multilib llvm python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="http://libcxx.llvm.org/"
+HOMEPAGE="https://libcxx.llvm.org/"
if [[ ${PV} != 9999 ]] ; then
- SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz"
+ SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz"
S="${WORKDIR}/${P}.src"
else
SRC_URI=""