summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/libieee1284
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/libieee1284')
-rw-r--r--sys-libs/libieee1284/Manifest1
-rw-r--r--sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild41
-rw-r--r--sys-libs/libieee1284/libieee1284-0.2.11-r2.ebuild44
-rw-r--r--sys-libs/libieee1284/libieee1284-0.2.11-r3.ebuild48
-rw-r--r--sys-libs/libieee1284/metadata.xml8
5 files changed, 142 insertions, 0 deletions
diff --git a/sys-libs/libieee1284/Manifest b/sys-libs/libieee1284/Manifest
new file mode 100644
index 000000000000..938c1dd9dbb0
--- /dev/null
+++ b/sys-libs/libieee1284/Manifest
@@ -0,0 +1 @@
+DIST libieee1284-0.2.11.tar.bz2 278804 SHA256 7730de107782e5d2b071bdcb5b06a44da74856f00ef4a9be85d1ba4806a38f1a SHA512 06cc3049ce15613d34e39dc71bc572843c61ab64077c29ef9a6257edb0849c98565ff612a4cf787bc9642a39f1c89b7c47a20fb27f2318105be82aad8d472bb9 WHIRLPOOL 16ab2763c11f32ec75c6df8d77a0b558ac572bcea487edb93e4eb67a7461ff96973a78a3fb11ec02d3f93cb71d0c586ee66b4ce5efa471c26f3507a820cc46ed
diff --git a/sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild b/sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild
new file mode 100644
index 000000000000..b120d255106f
--- /dev/null
+++ b/sys-libs/libieee1284/libieee1284-0.2.11-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2"
+inherit python
+
+DESCRIPTION="Library to query devices using IEEE1284"
+HOMEPAGE="http://cyberelk.net/tim/libieee1284/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="doc python"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-sgml-utils
+ >=app-text/docbook-sgml-dtd-4.1
+ app-text/docbook-dsssl-stylesheets
+ dev-perl/XML-RegExp
+ )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ $(use_with python) \
+ --disable-dependency-tracking
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README* TODO doc/interface* || die
+}
diff --git a/sys-libs/libieee1284/libieee1284-0.2.11-r2.ebuild b/sys-libs/libieee1284/libieee1284-0.2.11-r2.ebuild
new file mode 100644
index 000000000000..0823473f3a54
--- /dev/null
+++ b/sys-libs/libieee1284/libieee1284-0.2.11-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2"
+inherit python
+
+DESCRIPTION="Library to query devices using IEEE1284"
+HOMEPAGE="http://cyberelk.net/tim/libieee1284/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="doc python static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-sgml-utils
+ >=app-text/docbook-sgml-dtd-4.1
+ app-text/docbook-dsssl-stylesheets
+ dev-perl/XML-RegExp
+ )"
+
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_with python) \
+ --disable-dependency-tracking
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -name '*.la' -delete
+ dodoc AUTHORS NEWS README* TODO doc/interface*
+}
diff --git a/sys-libs/libieee1284/libieee1284-0.2.11-r3.ebuild b/sys-libs/libieee1284/libieee1284-0.2.11-r3.ebuild
new file mode 100644
index 000000000000..0af6c8511d77
--- /dev/null
+++ b/sys-libs/libieee1284/libieee1284-0.2.11-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+PYTHON_DEPEND="python? 2"
+inherit eutils python multilib-minimal
+
+DESCRIPTION="Library to query devices using IEEE1284"
+HOMEPAGE="http://cyberelk.net/tim/libieee1284/index.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="doc python static-libs"
+
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r9
+ !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-sgml-utils
+ >=app-text/docbook-sgml-dtd-4.1
+ app-text/docbook-dsssl-stylesheets
+ dev-perl/XML-RegExp
+ )"
+
+DOCS="AUTHORS NEWS README* TODO doc/interface*"
+
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
+multilib_src_configure() {
+ local myconf="--without-python"
+ multilib_is_native_abi && myconf="$(use_with python)"
+
+ ECONF_SOURCE="${S}" econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
+}
diff --git a/sys-libs/libieee1284/metadata.xml b/sys-libs/libieee1284/metadata.xml
new file mode 100644
index 000000000000..bec15437c073
--- /dev/null
+++ b/sys-libs/libieee1284/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <upstream>
+ <remote-id type="sourceforge">libieee1284</remote-id>
+ </upstream>
+</pkgmetadata>