summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/libixp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/libixp')
-rw-r--r--sys-libs/libixp/Manifest1
-rw-r--r--sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild50
-rw-r--r--sys-libs/libixp/metadata.xml5
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-libs/libixp/Manifest b/sys-libs/libixp/Manifest
new file mode 100644
index 000000000000..5be3f0c3f446
--- /dev/null
+++ b/sys-libs/libixp/Manifest
@@ -0,0 +1 @@
+DIST libixp-0.5_p20110208.tar.xz 655956 SHA256 66ce92b25486505d04b97d838fb9b102cd1edb1455d90916d00dc38369b2c06b
diff --git a/sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild b/sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild
new file mode 100644
index 000000000000..ea2a3bdab2d2
--- /dev/null
+++ b/sys-libs/libixp/libixp-0.5_p20110208-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# hg clone http://hg.suckless.org/libixp
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+DESCRIPTION="A stand-alone client/server 9P library including ixpc client"
+HOMEPAGE="http://libs.suckless.org/libixp"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/xz-utils"
+
+pkg_setup() {
+ myixpconf=(
+ PREFIX="/usr"
+ LIBDIR="/usr/$(get_libdir)"
+ CC="$(tc-getCC) -c"
+ LD="$(tc-getCC) ${LDFLAGS}"
+ AR="$(tc-getAR) crs"
+ MAKESO="1"
+ SOLDFLAGS="-shared"
+ )
+}
+
+src_prepare() {
+ # http://code.google.com/p/libixp/issues/detail?id=2
+ sed -i -e 's:ixp_serve9pconn:ixp_serve9conn:' include/ixp.h || die
+
+ # http://bugs.gentoo.org/393299 http://code.google.com/p/wmii/issues/detail?id=247
+ sed -i -e '69s:uint32_t:unsigned long:' include/ixp.h || die
+}
+
+src_compile() {
+ emake "${myixpconf[@]}"
+}
+
+src_install() {
+ emake "${myixpconf[@]}" DESTDIR="${D}" install
+ dolib.so lib/libixp{,_pthread}.so
+ dodoc NEWS
+}
diff --git a/sys-libs/libixp/metadata.xml b/sys-libs/libixp/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/sys-libs/libixp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>