summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild')
-rw-r--r--sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild b/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild
new file mode 100644
index 000000000000..c5b159bc1773
--- /dev/null
+++ b/sys-libs/libkudzu/libkudzu-1.2.57.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils linux-info flag-o-matic toolchain-funcs
+
+DESCRIPTION="Red Hat Hardware detection tools"
+HOMEPAGE="http://rhlinux.redhat.com/kudzu/"
+SRC_URI="mirror://gentoo/kudzu-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 -mips ppc ppc64 sparc x86"
+IUSE="zlib"
+
+DEPEND="
+ dev-libs/popt
+ >=sys-apps/pciutils-2.2.4[zlib?]
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="
+ ${DEPEND}
+ sys-apps/hwdata-gentoo
+ !sys-apps/kudzu
+"
+
+S=${WORKDIR}/kudzu-${PV}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/kudzu-${PV}-sbusfix.patch \
+ "${FILESDIR}"/kudzu-${PV}-sparc-keyboard.patch
+}
+
+src_configure() {
+ if use zlib; then
+ sed -i -e 's| -lpci| -lz -lpci|g' Makefile || die
+ fi
+ # Fix the modules directory to match Gentoo layout.
+ sed -i -e 's|/etc/modutils/kudzu|/etc/modules.d/kudzu|g' *.* || die
+
+ tc-export CC
+}
+
+src_compile() {
+ emake \
+ $( usex ppc ARCH='ppc' ARCH=$(tc-arch-kernel) ) \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB) \
+ RPM_OPT_FLAGS="${CFLAGS}" \
+ libkudzu.a libkudzu_loader.a
+}
+
+src_install() {
+ insinto /usr/include/kudzu
+ doins *.h
+
+ dolib.a libkudzu.a libkudzu_loader.a
+
+ keepdir /etc/sysconfig
+}