summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-08 23:04:15 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-08 23:18:57 +0100
commit8fabadb5c4c66c5fea35bc9605d8e2e5e3a0d400 (patch)
tree59924f102612fc22e6d532539ea8f5eccf8c4ee4 /sys-libs/libomp/libomp-6.0.9999.ebuild
parentsys-libs/libcxx: Control lit job count (diff)
downloadgentoo-8fabadb5c4c66c5fea35bc9605d8e2e5e3a0d400.tar.gz
gentoo-8fabadb5c4c66c5fea35bc9605d8e2e5e3a0d400.tar.bz2
gentoo-8fabadb5c4c66c5fea35bc9605d8e2e5e3a0d400.zip
sys-libs/libomp: Control lit job count
Closes: https://bugs.gentoo.org/649554
Diffstat (limited to 'sys-libs/libomp/libomp-6.0.9999.ebuild')
-rw-r--r--sys-libs/libomp/libomp-6.0.9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/libomp/libomp-6.0.9999.ebuild b/sys-libs/libomp/libomp-6.0.9999.ebuild
index 01d1bd791b82..7f2edc10fee9 100644
--- a/sys-libs/libomp/libomp-6.0.9999.ebuild
+++ b/sys-libs/libomp/libomp-6.0.9999.ebuild
@@ -8,7 +8,7 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-multilib git-r3 linux-info python-any-r1
+inherit cmake-multilib git-r3 linux-info multiprocessing python-any-r1
DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
HOMEPAGE="https://openmp.llvm.org"
@@ -100,7 +100,7 @@ multilib_src_configure() {
use test && mycmakeargs+=(
# this project does not use standard LLVM cmake macros
-DOPENMP_LLVM_LIT_EXECUTABLE="${EPREFIX}/usr/bin/lit"
- -DOPENMP_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"