summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-08 11:03:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-08 11:34:27 +0100
commit75a5ec6e3daef1841d084314e971d92cad37e756 (patch)
treeebb181d83150009396c988739c63802cfc839724 /sys-libs/libomp
parentdev-libs/libclc: x86 stable wrt bug #822147 (diff)
downloadgentoo-75a5ec6e3daef1841d084314e971d92cad37e756.tar.gz
gentoo-75a5ec6e3daef1841d084314e971d92cad37e756.tar.bz2
gentoo-75a5ec6e3daef1841d084314e971d92cad37e756.zip
sys-libs/libomp: Fix finding llvm-link when using compiler shadow
Pass the path to llvm-link explicitly in order to fix finding it when the compiler directory is different than llvm-link directory. This happens e.g. when ccache is being used. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/libomp')
-rw-r--r--sys-libs/libomp/libomp-13.0.0-r1.ebuild (renamed from sys-libs/libomp/libomp-13.0.0.ebuild)3
-rw-r--r--sys-libs/libomp/libomp-13.0.0.9999.ebuild3
-rw-r--r--sys-libs/libomp/libomp-14.0.0.9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/sys-libs/libomp/libomp-13.0.0.ebuild b/sys-libs/libomp/libomp-13.0.0-r1.ebuild
index 980686f9e842..9009d8a82952 100644
--- a/sys-libs/libomp/libomp-13.0.0.ebuild
+++ b/sys-libs/libomp/libomp-13.0.0-r1.ebuild
@@ -103,6 +103,9 @@ multilib_src_configure() {
-DLIBOMPTARGET_BUILD_NVPTX_BCLIB=$(usex llvm_targets_NVPTX)
# a cheap hack to force clang
-DLIBOMPTARGET_NVPTX_CUDA_COMPILER="$(type -P "${CHOST}-clang")"
+ # upstream defaults to looking for it in clang dir
+ # this fails when ccache is being used
+ -DLIBOMPTARGET_NVPTX_BC_LINKER="$(type -P llvm-link)"
)
use test && mycmakeargs+=(
# this project does not use standard LLVM cmake macros
diff --git a/sys-libs/libomp/libomp-13.0.0.9999.ebuild b/sys-libs/libomp/libomp-13.0.0.9999.ebuild
index c16560830be1..8ff1b93cd2f6 100644
--- a/sys-libs/libomp/libomp-13.0.0.9999.ebuild
+++ b/sys-libs/libomp/libomp-13.0.0.9999.ebuild
@@ -102,6 +102,9 @@ multilib_src_configure() {
-DLIBOMPTARGET_BUILD_NVPTX_BCLIB=$(usex llvm_targets_NVPTX)
# a cheap hack to force clang
-DLIBOMPTARGET_NVPTX_CUDA_COMPILER="$(type -P "${CHOST}-clang")"
+ # upstream defaults to looking for it in clang dir
+ # this fails when ccache is being used
+ -DLIBOMPTARGET_NVPTX_BC_LINKER="$(type -P llvm-link)"
)
use test && mycmakeargs+=(
# this project does not use standard LLVM cmake macros
diff --git a/sys-libs/libomp/libomp-14.0.0.9999.ebuild b/sys-libs/libomp/libomp-14.0.0.9999.ebuild
index c16560830be1..8ff1b93cd2f6 100644
--- a/sys-libs/libomp/libomp-14.0.0.9999.ebuild
+++ b/sys-libs/libomp/libomp-14.0.0.9999.ebuild
@@ -102,6 +102,9 @@ multilib_src_configure() {
-DLIBOMPTARGET_BUILD_NVPTX_BCLIB=$(usex llvm_targets_NVPTX)
# a cheap hack to force clang
-DLIBOMPTARGET_NVPTX_CUDA_COMPILER="$(type -P "${CHOST}-clang")"
+ # upstream defaults to looking for it in clang dir
+ # this fails when ccache is being used
+ -DLIBOMPTARGET_NVPTX_BC_LINKER="$(type -P llvm-link)"
)
use test && mycmakeargs+=(
# this project does not use standard LLVM cmake macros