summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-19 23:36:42 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-19 23:36:42 +0200
commit09539eb735196c25f9871b2378bfc2c02428f6dd (patch)
tree075dec21f3d7251a3fa0541d0755ea16651e4367 /sys-libs/libosinfo/libosinfo-1.3.0.ebuild
parentsys-apps/osinfo-db-tools: bump to 1.3.0 (diff)
downloadgentoo-09539eb735196c25f9871b2378bfc2c02428f6dd.tar.gz
gentoo-09539eb735196c25f9871b2378bfc2c02428f6dd.tar.bz2
gentoo-09539eb735196c25f9871b2378bfc2c02428f6dd.zip
sys-libs/libosinfo: bump to 1.3.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'sys-libs/libosinfo/libosinfo-1.3.0.ebuild')
-rw-r--r--sys-libs/libosinfo/libosinfo-1.3.0.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/libosinfo/libosinfo-1.3.0.ebuild b/sys-libs/libosinfo/libosinfo-1.3.0.ebuild
new file mode 100644
index 000000000000..277498d87879
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-1.3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 udev vala
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="https://libosinfo.org/"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+IUSE="+introspection +vala test"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Unsure about osinfo-db-tools rdep, but at least fedora does it too
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=dev-libs/libxml2-2.6.0
+ >=dev-libs/libxslt-1.0.0
+ sys-apps/hwids[pci,usb]
+ sys-apps/osinfo-db-tools
+ sys-apps/osinfo-db
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+# perl dep is for pod2man, and configure.ac checks for it too now
+# Tests can use net-misc/curl, but they are automatically skipped if curl is not found, and
+# if it is found, then those tests are skipped at runtime if LIBOSINFO_NETWORK_TESTS is unset.
+# Due to potential network-sandbox we aren't enabling them (and one of them fails at 1.2.0).
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-libs/gobject-introspection-common
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+ test? (
+ >=sys-apps/osinfo-db-20180612
+ )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --with-usb-ids-path=/usr/share/misc/usb.ids \
+ --with-pci-ids-path=/usr/share/misc/pci.ids \
+ --disable-static \
+ $(use_enable test tests) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ --disable-coverage
+}