summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-05 21:55:50 +0000
committerSam James <sam@gentoo.org>2021-11-05 22:10:48 +0000
commitd7b7d0c23c6ed894ed37937833dcc50981a514af (patch)
tree9c565884d430bed98c4f7e6f7858a1d5d64f71e7 /sys-libs/libseccomp/libseccomp-9999.ebuild
parentdev-ml/dose3: 7.0.0 bump (diff)
downloadgentoo-d7b7d0c23c6ed894ed37937833dcc50981a514af.tar.gz
gentoo-d7b7d0c23c6ed894ed37937833dcc50981a514af.tar.bz2
gentoo-d7b7d0c23c6ed894ed37937833dcc50981a514af.zip
sys-libs/libseccomp: add 2.5.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libseccomp/libseccomp-9999.ebuild')
-rw-r--r--sys-libs/libseccomp/libseccomp-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sys-libs/libseccomp/libseccomp-9999.ebuild b/sys-libs/libseccomp/libseccomp-9999.ebuild
index eea16fa2bbf5..e0277c89c970 100644
--- a/sys-libs/libseccomp/libseccomp-9999.ebuild
+++ b/sys-libs/libseccomp/libseccomp-9999.ebuild
@@ -22,7 +22,8 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="python static-libs"
+IUSE="python static-libs test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
@@ -39,10 +40,14 @@ DEPEND="${DEPEND} >=sys-kernel/linux-headers-4.3"
src_prepare() {
local PATCHES=(
"${FILESDIR}/libseccomp-python-shared.patch"
+ "${FILESDIR}/libseccomp-2.5.3-skip-valgrind.patch"
)
+
default
+
if [[ "${PV}" == *9999 ]] ; then
- sed -i -e "s/0.0.0/${PRERELEASE}/" configure.ac
+ sed -i -e "s/0.0.0/${PRERELEASE}/" configure.ac || die
+
eautoreconf
fi
}
@@ -52,12 +57,14 @@ multilib_src_configure() {
$(use_enable static-libs static)
--disable-python
)
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
do_python() {
# setup.py reads VERSION_RELEASE from the environment
local -x VERSION_RELEASE=${PRERELEASE-${PV}}
+
pushd "${BUILD_DIR}/src/python" >/dev/null || die
"$@"
popd >/dev/null || die
@@ -72,6 +79,7 @@ multilib_src_compile() {
rm -r "${BUILD_DIR}/src/python" || die
cp -r "${S}/src/python" "${BUILD_DIR}/src/python" || die
local -x CPPFLAGS="-I\"${BUILD_DIR}/include\" -I\"${S}/include\" ${CPPFLAGS}"
+
do_python distutils-r1_src_compile
fi
}
@@ -86,5 +94,6 @@ multilib_src_install() {
multilib_src_install_all() {
find "${ED}" -type f -name "${PN}.la" -delete || die
+
einstalldocs
}