summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-08-05 00:52:54 +0800
committerJason Zaman <perfinion@gentoo.org>2016-08-08 01:05:18 +0800
commit0c73493b4c6e4a222d19b84cc83f4f461fd232f3 (patch)
treeb8045deb94ded7d76ae0497e03e6d873d4855be6 /sys-libs/libsemanage/files
parentsys-libs/libselinux: update to eapi6 (diff)
downloadgentoo-0c73493b4c6e4a222d19b84cc83f4f461fd232f3.tar.gz
gentoo-0c73493b4c6e4a222d19b84cc83f4f461fd232f3.tar.bz2
gentoo-0c73493b4c6e4a222d19b84cc83f4f461fd232f3.zip
sys-libs/libsemanage: update to eapi6 and update build patch
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-libs/libsemanage/files')
-rw-r--r--sys-libs/libsemanage/files/libsemanage-2.6-build-paths.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-libs/libsemanage/files/libsemanage-2.6-build-paths.patch b/sys-libs/libsemanage/files/libsemanage-2.6-build-paths.patch
new file mode 100644
index 000000000000..86e5c7e9a6b7
--- /dev/null
+++ b/sys-libs/libsemanage/files/libsemanage-2.6-build-paths.patch
@@ -0,0 +1,35 @@
+there's no point in using -I/-L flags to the system paths and this breaks
+cross-compiling. just drop them.
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -60,7 +60,7 @@
+ SWIG_CFLAGS += -Wno-error -Wno-unused-but-set-variable -Wno-unused-variable -Wno-shadow \
+ -Wno-unused-parameter
+
+-override CFLAGS += -I../include -I$(INCLUDEDIR) -D_GNU_SOURCE
++override CFLAGS += -I../include -D_GNU_SOURCE
+ RANLIB ?= ranlib
+
+ SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./
+@@ -82,17 +82,17 @@
+ $(CC) $(CFLAGS) $(SWIG_CFLAGS) $(RUBYINC) -fPIC -DSHARED -c -o $@ $<
+
+ $(SWIGSO): $(SWIGLOBJ)
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $< -L. -lsemanage -L$(LIBDIR)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $< -L. -lsemanage
+
+ $(SWIGRUBYSO): $(SWIGRUBYLOBJ)
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -L. -lsemanage -L$(LIBDIR)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -L. -lsemanage
+
+ $(LIBA): $(OBJS)
+ $(AR) rcs $@ $^
+ $(RANLIB) $@
+
+ $(LIBSO): $(LOBJS)
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -lustr -L$(LIBDIR) -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -lustr -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
+ ln -sf $@ $(TARGET)
+
+ $(LIBPC): $(LIBPC).in ../VERSION