summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-11-20 13:19:08 +0800
committerJason Zaman <perfinion@gentoo.org>2016-11-20 13:26:22 +0800
commit13e768af2d8998876b0e25710d2b6453e6844b6b (patch)
tree7b8d9547b500cd72338badabf10b778eb125329e /sys-libs/libsemanage
parentsys-apps/selinux-python: New package live ebuild split from policycoreutils (diff)
downloadgentoo-13e768af2d8998876b0e25710d2b6453e6844b6b.tar.gz
gentoo-13e768af2d8998876b0e25710d2b6453e6844b6b.tar.bz2
gentoo-13e768af2d8998876b0e25710d2b6453e6844b6b.zip
sys-libs/libsemanage: update build paths patch for live ebuild
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-libs/libsemanage')
-rw-r--r--sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch37
-rw-r--r--sys-libs/libsemanage/libsemanage-9999.ebuild2
2 files changed, 38 insertions, 1 deletions
diff --git a/sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch b/sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch
new file mode 100644
index 000000000000..0069c96ebdd4
--- /dev/null
+++ b/sys-libs/libsemanage/files/libsemanage-2.7-build-paths.patch
@@ -0,0 +1,37 @@
+there's no point in using -I/-L flags to the system paths and this breaks
+cross-compiling. just drop them.
+
+diff --git a/libsemanage/src/Makefile b/libsemanage/src/Makefile
+index ef25902..7aad334 100644
+--- libsemanage/src/Makefile
++++ libsemanage/src/Makefile
+@@ -61,7 +61,7 @@ CFLAGS ?= -Werror -Wall -W -Wundef -Wshadow -Wmissing-noreturn -Wmissing-format-
+ SWIG_CFLAGS += -Wno-error -Wno-unused-but-set-variable -Wno-unused-variable -Wno-shadow \
+ -Wno-unused-parameter
+
+-override CFLAGS += -I../include -I$(INCLUDEDIR) -D_GNU_SOURCE
++override CFLAGS += -I../include -D_GNU_SOURCE
+ RANLIB ?= ranlib
+
+ SWIG = swig -Wall -python -o $(SWIGCOUT) -outdir ./
+@@ -81,17 +81,17 @@ $(SWIGRUBYLOBJ): $(SWIGRUBYCOUT)
+ $(CC) $(CFLAGS) $(SWIG_CFLAGS) $(RUBYINC) -fPIC -DSHARED -c -o $@ $<
+
+ $(SWIGSO): $(SWIGLOBJ)
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $< -L. -lsemanage $(PYLIBS) -L$(LIBDIR)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $< -L. -lsemanage $(PYLIBS)
+
+ $(SWIGRUBYSO): $(SWIGRUBYLOBJ)
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -L. -lsemanage $(RUBYLIBS) -L$(LIBDIR)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -L. -lsemanage $(RUBYLIBS)
+
+ $(LIBA): $(OBJS)
+ $(AR) rcs $@ $^
+ $(RANLIB) $@
+
+ $(LIBSO): $(LOBJS)
+- $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -lustr -L$(LIBDIR) -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -lsepol -laudit -lselinux -lbz2 -lustr -Wl,-soname,$(LIBSO),--version-script=libsemanage.map,-z,defs
+ ln -sf $@ $(TARGET)
+
+ $(LIBPC): $(LIBPC).in ../VERSION
diff --git a/sys-libs/libsemanage/libsemanage-9999.ebuild b/sys-libs/libsemanage/libsemanage-9999.ebuild
index ae2129710625..5fdf0a04c988 100644
--- a/sys-libs/libsemanage/libsemanage-9999.ebuild
+++ b/sys-libs/libsemanage/libsemanage-9999.ebuild
@@ -72,7 +72,7 @@ src_prepare() {
echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
echo "bzip-small=true" >> "${S}/src/semanage.conf"
- eapply "${FILESDIR}"/${PN}-2.6-build-paths.patch
+ eapply "${FILESDIR}"/${PN}-2.7-build-paths.patch
eapply_user