summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-05-25 12:32:10 +0800
committerJason Zaman <perfinion@gentoo.org>2018-05-25 15:27:36 +0800
commit739e3f6159244fc53dd42c418142dde981c835d6 (patch)
tree901440ddb3f8c619d049c0c845214073f1653025 /sys-libs/libsemanage
parentsys-libs/libselinux: bump to 2.8 (diff)
downloadgentoo-739e3f6159244fc53dd42c418142dde981c835d6.tar.gz
gentoo-739e3f6159244fc53dd42c418142dde981c835d6.tar.bz2
gentoo-739e3f6159244fc53dd42c418142dde981c835d6.zip
sys-libs/libsemanage: bump to 2.8
Package-Manager: Portage-2.3.39, Repoman-2.3.9
Diffstat (limited to 'sys-libs/libsemanage')
-rw-r--r--sys-libs/libsemanage/Manifest1
-rw-r--r--sys-libs/libsemanage/libsemanage-2.8.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/sys-libs/libsemanage/Manifest b/sys-libs/libsemanage/Manifest
index 905a1d422d03..a30a4e94fa8b 100644
--- a/sys-libs/libsemanage/Manifest
+++ b/sys-libs/libsemanage/Manifest
@@ -3,3 +3,4 @@ DIST libsemanage-2.7.tar.gz 153465 BLAKE2B fb585b8caba394757dbabb7c0825086059578
DIST libsemanage-2.8-rc1.tar.gz 154131 BLAKE2B c0110cd67f04bf599b491335078af69852f23130ed321f0608fdefc1ba0cd425080fff07a1a267382c2610716d8bc766dd6ed34f5aae78818432542132b0b906 SHA512 befeaf587e36d1bcde068f9c46143b76c075122ed06c9290f9bdb16f5fa5d12dabbd9f190fc2584c87234c44f0778b434bf6cc5ca350a5de390cfec2f9fa1307
DIST libsemanage-2.8-rc2.tar.gz 154148 BLAKE2B c376ae7b728b50010c9a9dfcb69787667ba2096fb9c4663012a4e33d100bd093f2a9136a0ae08cd2d2dc28ec97c7c25106b9f19bbceb9477fd7d58bce556141d SHA512 0ee4bafa1d407796b0a79794fef92625c54ea72cd861f8426b142f0e80954772f28bf787013514bc1f6f55f31625cf71ef246a81564d1ce97a61bba9fbd81fce
DIST libsemanage-2.8-rc3.tar.gz 154158 BLAKE2B d03bf87f5c49928c31b61be87c9bcd5d295694e9a59884291bf2157e56d0b4a1aba39b350c2e6388418f8f3f4ffd0b7afc3219a596368103be2c5308f00fa36b SHA512 b3a6cb11684890ef7c707a36fb559abdc836cc819a4eb481818393816470a9231260763087fa0d6d23a224dcee65d199e1704fc01433336b1838f2ff047d8a6a
+DIST libsemanage-2.8.tar.gz 154200 BLAKE2B db987e42aed7177cd9b3d1e495c97878a816fe78d7c73631f475649d0ab4182e5966a9ee691f2d59863eab2b7a62f608bc00f0789f22401a54f18b41f6ebfb68 SHA512 53f09c79da168a79b853f55e0f1c20a96229df9d82929c514bcaf72697446ae836f7f0457fc0056d2418cc6d0712157faf0152881518fe84a1b1b9b9af17e7ef
diff --git a/sys-libs/libsemanage/libsemanage-2.8.ebuild b/sys-libs/libsemanage/libsemanage-2.8.ebuild
new file mode 100644
index 000000000000..0cc1dbbf8b49
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-2.8.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit multilib python-r1 toolchain-funcs multilib-minimal
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20180524"
+
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}[${MULTILIB_USEDEP}]
+ >=sys-libs/libselinux-${SELNX_VER}[${MULTILIB_USEDEP}]
+ >=sys-process/audit-2.2.2[${MULTILIB_USEDEP}]
+ >=dev-libs/ustr-1.0.4-r2[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ python? (
+ >=dev-lang/swig-2.0.4-r1
+ virtual/pkgconfig
+ )"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
+ echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
+ echo "# or debugging of policy." >> "${S}/src/semanage.conf"
+ echo "save-linked=false" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
+ echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
+ echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
+ echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
+ echo "# would catch." >> "${S}/src/semanage.conf"
+ echo "expand-check=1" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Modules in the module store can be compressed" >> "${S}/src/semanage.conf"
+ echo "# with bzip2. Set this to the bzip2 blocksize" >> "${S}/src/semanage.conf"
+ echo "# 1-9 when compressing. The higher the number," >> "${S}/src/semanage.conf"
+ echo "# the more memory is traded off for disk space." >> "${S}/src/semanage.conf"
+ echo "# Set to 0 to disable bzip2 compression." >> "${S}/src/semanage.conf"
+ echo "bzip-blocksize=0" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Reduce memory usage for bzip2 compression and" >> "${S}/src/semanage.conf"
+ echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
+ echo "bzip-small=true" >> "${S}/src/semanage.conf"
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ all
+
+ if multilib_is_native_abi && use python; then
+ building_py() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ "$@"
+ }
+ python_foreach_impl building_py swigify
+ python_foreach_impl building_py pywrap
+ fi
+}
+
+multilib_src_install() {
+ emake \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${ED}" install
+
+ if multilib_is_native_abi && use python; then
+ installation_py() {
+ emake DESTDIR="${ED}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install-pywrap
+ python_optimize # bug 531638
+ }
+ python_foreach_impl installation_py
+ fi
+}
+
+pkg_postinst() {
+ # Migrate the SELinux semanage configuration store if not done already
+ local selinuxtype=$(awk -F'=' '/SELINUXTYPE=/ {print $2}' "${EROOT}"/etc/selinux/config 2>/dev/null)
+ if [ -n "${selinuxtype}" ] && [ ! -d "${EROOT}"/var/lib/selinux/${mcs}/active ] ; then
+ ewarn "Since the 2.4 SELinux userspace, the policy module store is moved"
+ ewarn "from /etc/selinux to /var/lib/selinux. The migration will be run now."
+ ewarn "If there are any issues, it can be done manually by running:"
+ ewarn "/usr/libexec/selinux/semanage_migrate_store"
+ ewarn "For more information, please see"
+ ewarn "- https://github.com/SELinuxProject/selinux/wiki/Policy-Store-Migration"
+ fi
+
+ # Run the store migration without rebuilds
+ for POLICY_TYPE in ${POLICY_TYPES} ; do
+ if [ ! -d "${EROOT}/var/lib/selinux/${POLICY_TYPE}/active" ] ; then
+ einfo "Migrating store ${POLICY_TYPE} (without policy rebuild)."
+ "${EROOT}/usr/libexec/selinux/semanage_migrate_store" -n -s "${POLICY_TYPE}" || die "Failed to migrate store ${POLICY_TYPE}"
+ fi
+ done
+}