summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-02-12 23:42:18 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-02-12 23:42:24 +0000
commitc50e03e331565aa875dc7a081d9c0f865869f563 (patch)
treea1cdeaf5e133747236de6f6e6676d0b09650f2ba /sys-libs/libunwind
parentsci-geosciences/osm2pgsql: EAPI-7 bump, switch to cmake.eclass (diff)
downloadgentoo-c50e03e331565aa875dc7a081d9c0f865869f563.tar.gz
gentoo-c50e03e331565aa875dc7a081d9c0f865869f563.tar.bz2
gentoo-c50e03e331565aa875dc7a081d9c0f865869f563.zip
sys-libs/libunwind: add -fcommon workaround for gcc-10, bug #
The source fix is not trivial as it's not clear where global shloud be defined: in common or per-arch files. Use -fcommon downstream and leave proper fix to upstream ticket. Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/706560 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/libunwind')
-rw-r--r--sys-libs/libunwind/libunwind-1.2.1-r3.ebuild8
-rw-r--r--sys-libs/libunwind/libunwind-1.3.1.ebuild8
2 files changed, 12 insertions, 4 deletions
diff --git a/sys-libs/libunwind/libunwind-1.2.1-r3.ebuild b/sys-libs/libunwind/libunwind-1.2.1-r3.ebuild
index 10fa1ecd3f92..9482711db4de 100644
--- a/sys-libs/libunwind/libunwind-1.2.1-r3.ebuild
+++ b/sys-libs/libunwind/libunwind-1.2.1-r3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_PV=${PV/_/-}
MY_P=${PN}-${MY_PV}
-inherit autotools eutils libtool multilib-minimal
+inherit autotools eutils flag-o-matic libtool multilib-minimal
DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
@@ -62,6 +62,10 @@ src_prepare() {
elibtoolize
eautoreconf
+
+ # Let's wait for proer fix upstream in https://github.com/libunwind/libunwind/issues/154
+ # Meanwhile workaround for gcc-10 with -fcommon, bug #706560
+ append-cflags -fcommon
}
multilib_src_configure() {
diff --git a/sys-libs/libunwind/libunwind-1.3.1.ebuild b/sys-libs/libunwind/libunwind-1.3.1.ebuild
index e91ad4925c30..908da4b4c86d 100644
--- a/sys-libs/libunwind/libunwind-1.3.1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.3.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PV=${PV/_/-}
MY_P=${PN}-${MY_PV}
-inherit autotools eutils libtool multilib-minimal
+inherit autotools eutils flag-o-matic libtool multilib-minimal
DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
@@ -58,6 +58,10 @@ src_prepare() {
elibtoolize
eautoreconf
+
+ # Let's wait for proer fix upstream in https://github.com/libunwind/libunwind/issues/154
+ # Meanwhile workaround for gcc-10 with -fcommon, bug #706560
+ append-cflags -fcommon
}
multilib_src_configure() {