summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-12-01 13:59:52 +0100
committerJeroen Roovers <jer@gentoo.org>2018-12-01 14:03:28 +0100
commit3a2d90d1272deaeeadf83ea5fa71e9c1aa36003e (patch)
tree984b146c2b8d5f113178d1101fa638ee2ec0fefd /sys-libs/libvpd/libvpd-2.2.6.ebuild
parentdev-libs/mongo-cxx-driver: tweak for boost-167, bug #671422 (diff)
downloadgentoo-3a2d90d1272deaeeadf83ea5fa71e9c1aa36003e.tar.gz
gentoo-3a2d90d1272deaeeadf83ea5fa71e9c1aa36003e.tar.bz2
gentoo-3a2d90d1272deaeeadf83ea5fa71e9c1aa36003e.zip
sys-libs/libvpd: Version 2.2.6
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-libs/libvpd/libvpd-2.2.6.ebuild')
-rw-r--r--sys-libs/libvpd/libvpd-2.2.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-libs/libvpd/libvpd-2.2.6.ebuild b/sys-libs/libvpd/libvpd-2.2.6.ebuild
new file mode 100644
index 000000000000..a85c190bf64e
--- /dev/null
+++ b/sys-libs/libvpd/libvpd-2.2.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit udev
+
+DESCRIPTION="Library implementation for listing vpds"
+HOMEPAGE="https://sourceforge.net/projects/linux-diag/"
+SRC_URI="https://sourceforge.net/projects/linux-diag/files/libvpd/${PV}/libvpd-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="static-libs"
+
+DEPEND="
+ >=dev-db/sqlite-3.7.8
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.6-localstatedir.patch
+)
+
+src_configure() {
+ # sysconfdir is used only to establish where the udev rules file should go
+ # unfortunately it also adds the subdirs on its own so we strip it down to
+ # dirname
+ econf \
+ $(use_enable static-libs static) \
+ --sysconfdir="$( dirname $(get_udevdir) )"
+}
+
+src_install(){
+ default
+ keepdir /var/lib/lsvpd
+ find "${D}" -name '*.la' -delete || die
+}