summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-19 10:04:34 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-19 10:14:07 +0100
commita1115ae7102c0033fd85ea5a5cd087ea69e449b0 (patch)
treee565fd578f7eb4df04822eff404708751857151b /sys-libs/llvm-libunwind
parentsys-libs/compiler-rt-sanitizers: Bump to 4.0.0rc1 (diff)
downloadgentoo-a1115ae7102c0033fd85ea5a5cd087ea69e449b0.tar.gz
gentoo-a1115ae7102c0033fd85ea5a5cd087ea69e449b0.tar.bz2
gentoo-a1115ae7102c0033fd85ea5a5cd087ea69e449b0.zip
sys-libs/llvm-libunwind: Bump to 4.0.0rc1
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild
new file mode 100644
index 000000000000..f824d98314ef
--- /dev/null
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
+inherit cmake-multilib git-r3
+
+DESCRIPTION="C++ runtime stack unwinder from LLVM"
+HOMEPAGE="https://github.com/llvm-mirror/libunwind"
+SRC_URI=""
+EGIT_REPO_URI="http://llvm.org/git/libunwind.git
+ https://github.com/llvm-mirror/libunwind.git"
+EGIT_BRANCH="release_40"
+EGIT_COMMIT="9f88e323c3d0926f52ab3d4a5379eefd92ff28c2"
+
+LICENSE="|| ( UoI-NCSA MIT )"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +static-libs"
+
+RDEPEND="!sys-libs/libunwind"
+# LLVM 4 required for llvm-config --cmakedir
+DEPEND=">=sys-devel/llvm-4"
+
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+multilib_src_configure() {
+ local libdir=$(get_libdir)
+
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+ -DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
+ -DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+
+ # install headers like sys-libs/libunwind
+ doheader "${S}"/include/*.h
+}