summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-10 15:16:03 +0100
committerSam James <sam@gentoo.org>2023-09-10 15:16:59 +0100
commitf8fa80bed10eacdc4269f6d8a08985a6cf6df1dc (patch)
tree6b57f3aee9d141f5bf82c60f63384b6774c72e83 /sys-libs/llvm-libunwind
parentapp-shells/fzf: keyword ~arm + Makefile fix for armv8l (diff)
downloadgentoo-f8fa80bed10eacdc4269f6d8a08985a6cf6df1dc.tar.gz
gentoo-f8fa80bed10eacdc4269f6d8a08985a6cf6df1dc.tar.bz2
gentoo-f8fa80bed10eacdc4269f6d8a08985a6cf6df1dc.zip
sys-libs/llvm-libunwind: avoid spurious assertions with USE=-debug
Respect upstream build type assumptions where they do: * -DLIBUNWIND_ENABLE_ASSERTIONS=ON => -DCMAKE_BUILD_TYPE=DEBUG => -UNDEBUG -DCMAKE_BUILD_TYPE!=debug => -DNDEBUG * -DLIBUNWIND_ENABLE_ASSERTIONS=OFF => -UNDEBUG See also https://github.com/llvm/llvm-project/issues/86#issuecomment-1649668826. Bug: https://github.com/libunwind/libunwind/issues/138 Bug: https://github.com/llvm/llvm-project/issues/86 Bug: https://github.com/llvm/llvm-project/issues/55584 Closes: https://bugs.gentoo.org/910436 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/llvm-libunwind')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-16.0.6-r1.ebuild (renamed from sys-libs/llvm-libunwind/llvm-libunwind-16.0.6.ebuild)9
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-17.0.0.9999.ebuild9
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-17.0.0_rc4-r1.ebuild (renamed from sys-libs/llvm-libunwind/llvm-libunwind-17.0.0_rc4.ebuild)9
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild9
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-18.0.0_pre20230906-r1.ebuild (renamed from sys-libs/llvm-libunwind/llvm-libunwind-18.0.0_pre20230906.ebuild)9
5 files changed, 45 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.6.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.6-r1.ebuild
index 9d53bcd51939..18d5066e295f 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.6.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.6-r1.ebuild
@@ -67,6 +67,15 @@ multilib_src_configure() {
local use_compiler_rt=OFF
[[ $(tc-get-c-rtlib) == compiler-rt ]] && use_compiler_rt=ON
+ # Respect upstream build type assumptions (bug #910436) where they do:
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=ON =>
+ # -DCMAKE_BUILD_TYPE=DEBUG => -UNDEBUG
+ # -DCMAKE_BUILD_TYPE!=debug => -DNDEBUG
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=OFF =>
+ # -UNDEBUG
+ # See also https://github.com/llvm/llvm-project/issues/86#issuecomment-1649668826.
+ use debug || append-cppflags -DNDEBUG
+
local mycmakeargs=(
-DCMAKE_CXX_COMPILER_TARGET="${CHOST}"
-DPython3_EXECUTABLE="${PYTHON}"
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-17.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-17.0.0.9999.ebuild
index 43f8868fc308..94ec81df1452 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-17.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-17.0.0.9999.ebuild
@@ -67,6 +67,15 @@ multilib_src_configure() {
local use_compiler_rt=OFF
[[ $(tc-get-c-rtlib) == compiler-rt ]] && use_compiler_rt=ON
+ # Respect upstream build type assumptions (bug #910436) where they do:
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=ON =>
+ # -DCMAKE_BUILD_TYPE=DEBUG => -UNDEBUG
+ # -DCMAKE_BUILD_TYPE!=debug => -DNDEBUG
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=OFF =>
+ # -UNDEBUG
+ # See also https://github.com/llvm/llvm-project/issues/86#issuecomment-1649668826.
+ use debug || append-cppflags -DNDEBUG
+
local mycmakeargs=(
-DCMAKE_CXX_COMPILER_TARGET="${CHOST}"
-DPython3_EXECUTABLE="${PYTHON}"
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-17.0.0_rc4.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-17.0.0_rc4-r1.ebuild
index 43f8868fc308..94ec81df1452 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-17.0.0_rc4.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-17.0.0_rc4-r1.ebuild
@@ -67,6 +67,15 @@ multilib_src_configure() {
local use_compiler_rt=OFF
[[ $(tc-get-c-rtlib) == compiler-rt ]] && use_compiler_rt=ON
+ # Respect upstream build type assumptions (bug #910436) where they do:
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=ON =>
+ # -DCMAKE_BUILD_TYPE=DEBUG => -UNDEBUG
+ # -DCMAKE_BUILD_TYPE!=debug => -DNDEBUG
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=OFF =>
+ # -UNDEBUG
+ # See also https://github.com/llvm/llvm-project/issues/86#issuecomment-1649668826.
+ use debug || append-cppflags -DNDEBUG
+
local mycmakeargs=(
-DCMAKE_CXX_COMPILER_TARGET="${CHOST}"
-DPython3_EXECUTABLE="${PYTHON}"
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild
index 43f8868fc308..94ec81df1452 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0.9999.ebuild
@@ -67,6 +67,15 @@ multilib_src_configure() {
local use_compiler_rt=OFF
[[ $(tc-get-c-rtlib) == compiler-rt ]] && use_compiler_rt=ON
+ # Respect upstream build type assumptions (bug #910436) where they do:
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=ON =>
+ # -DCMAKE_BUILD_TYPE=DEBUG => -UNDEBUG
+ # -DCMAKE_BUILD_TYPE!=debug => -DNDEBUG
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=OFF =>
+ # -UNDEBUG
+ # See also https://github.com/llvm/llvm-project/issues/86#issuecomment-1649668826.
+ use debug || append-cppflags -DNDEBUG
+
local mycmakeargs=(
-DCMAKE_CXX_COMPILER_TARGET="${CHOST}"
-DPython3_EXECUTABLE="${PYTHON}"
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0_pre20230906.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0_pre20230906-r1.ebuild
index 43f8868fc308..94ec81df1452 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0_pre20230906.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-18.0.0_pre20230906-r1.ebuild
@@ -67,6 +67,15 @@ multilib_src_configure() {
local use_compiler_rt=OFF
[[ $(tc-get-c-rtlib) == compiler-rt ]] && use_compiler_rt=ON
+ # Respect upstream build type assumptions (bug #910436) where they do:
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=ON =>
+ # -DCMAKE_BUILD_TYPE=DEBUG => -UNDEBUG
+ # -DCMAKE_BUILD_TYPE!=debug => -DNDEBUG
+ # -DLIBUNWIND_ENABLE_ASSERTIONS=OFF =>
+ # -UNDEBUG
+ # See also https://github.com/llvm/llvm-project/issues/86#issuecomment-1649668826.
+ use debug || append-cppflags -DNDEBUG
+
local mycmakeargs=(
-DCMAKE_CXX_COMPILER_TARGET="${CHOST}"
-DPython3_EXECUTABLE="${PYTHON}"