summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/lwp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/lwp')
-rw-r--r--sys-libs/lwp/Manifest3
-rw-r--r--sys-libs/lwp/files/lwp-2.0-amd64.patch28
-rw-r--r--sys-libs/lwp/lwp-2.2.ebuild33
-rw-r--r--sys-libs/lwp/lwp-2.5.ebuild33
-rw-r--r--sys-libs/lwp/lwp-2.6.ebuild21
-rw-r--r--sys-libs/lwp/metadata.xml5
6 files changed, 123 insertions, 0 deletions
diff --git a/sys-libs/lwp/Manifest b/sys-libs/lwp/Manifest
new file mode 100644
index 000000000000..f20b62feaaae
--- /dev/null
+++ b/sys-libs/lwp/Manifest
@@ -0,0 +1,3 @@
+DIST lwp-2.2.tar.gz 376136 SHA256 64a3570559083bee657551b6673037161f33b71ad55ee45812612c29df2924b0
+DIST lwp-2.5.tar.gz 404121 SHA256 6b6f55c75d4d5ada9a000824b1d39bc88efa2cfb33006778ccbe7111a7bd0aa2
+DIST lwp-2.6.tar.gz 372225 SHA256 4887fd7f74564552f53dfe42440f4777808a82b1249b2733ecfd062849a4d32d SHA512 ad8374ddf55ef9fddf9ce0b8d7c2ae0dc206e5108a01f278a37486070ab70e5bd7312f057863254b4fc430cfbed2c36f589807813e6a99067933142d5225395b WHIRLPOOL 205836226f86e77dfbc795bdf667f51b2c40b99cbc7bf5b998361472b6ad46b102c519d88e1afc503b259c9073ac7b155e322d134f5787d770517f3bf3a2e54d
diff --git a/sys-libs/lwp/files/lwp-2.0-amd64.patch b/sys-libs/lwp/files/lwp-2.0-amd64.patch
new file mode 100644
index 000000000000..64a1576f0894
--- /dev/null
+++ b/sys-libs/lwp/files/lwp-2.0-amd64.patch
@@ -0,0 +1,28 @@
+diff -ruN lwp-2.0/src/lwp.c lwp-2.0-fixed/src/lwp.c
+--- lwp-2.0/src/lwp.c 2005-03-25 17:50:56.000000000 +0100
++++ lwp-2.0-fixed/src/lwp.c 2005-05-05 14:32:56.580753096 +0200
+@@ -463,6 +463,16 @@
+ #ifndef MMAP_LWP_STACKS
+ stackptr = (char *) malloc(stacksize);
+ #else
++ pagesize = getpagesize();
++
++#if defined(__x86_64__)
++ /* [gb] Ensure minimal stack size. Heuristically determined
++ through tdb test that 2048 is too small when printf() et al. come
++ into action. */
++ if (stacksize < pagesize)
++ stacksize = pagesize;
++#endif
++
+ #ifdef MAP_ANON
+ stackptr = mmap(lwp_stackbase, stacksize, PROT_READ | PROT_WRITE,
+ MAP_PRIVATE | MAP_ANON, -1, 0);
+@@ -483,7 +493,6 @@
+ perror("stack: ");
+ assert(0);
+ }
+- pagesize = getpagesize();
+ lwp_stackbase += ((stacksize/pagesize) + 2) * pagesize;
+ #endif
+ if (!stackptr)
diff --git a/sys-libs/lwp/lwp-2.2.ebuild b/sys-libs/lwp/lwp-2.2.ebuild
new file mode 100644
index 000000000000..8d5af861ec94
--- /dev/null
+++ b/sys-libs/lwp/lwp-2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="sys-apps/grep
+ sys-apps/sed
+ sys-devel/libtool
+ sys-devel/gcc"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Was introduced for bug #34542, not sure if still needed
+ use amd64 && epatch "${FILESDIR}"/lwp-2.0-amd64.patch
+}
+
+src_install() {
+ einstall || die "einstall failed."
+ dodoc AUTHORS NEWS PORTING README
+}
diff --git a/sys-libs/lwp/lwp-2.5.ebuild b/sys-libs/lwp/lwp-2.5.ebuild
new file mode 100644
index 000000000000..4a849e035bf5
--- /dev/null
+++ b/sys-libs/lwp/lwp-2.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/grep
+ sys-apps/sed
+ sys-devel/libtool
+ sys-devel/gcc"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Was introduced for bug #34542, not sure if still needed
+ use amd64 && epatch "${FILESDIR}"/lwp-2.0-amd64.patch
+}
+
+src_install() {
+ einstall || die "einstall failed."
+ dodoc AUTHORS NEWS PORTING README
+}
diff --git a/sys-libs/lwp/lwp-2.6.ebuild b/sys-libs/lwp/lwp-2.6.ebuild
new file mode 100644
index 000000000000..8231b8ed9e95
--- /dev/null
+++ b/sys-libs/lwp/lwp-2.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Light weight process library (used by Coda). This is NOT libwww-perl"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/lwp/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ # Was introduced for bug #34542, not sure if still needed
+ use amd64 && epatch "${FILESDIR}"/lwp-2.0-amd64.patch
+}
diff --git a/sys-libs/lwp/metadata.xml b/sys-libs/lwp/metadata.xml
new file mode 100644
index 000000000000..ca66751dee2f
--- /dev/null
+++ b/sys-libs/lwp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-fs</herd>
+</pkgmetadata>