summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-02-16 18:30:40 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-02-16 18:31:29 -0500
commita77db1ace19e04f6da7ac180cc035ccf567c0ff2 (patch)
treec6d11e8f454d2e993be9ac96328d4e22625771be /sys-libs/musl
parentapp-admin/fleet: Fix invalid maintainer (diff)
downloadgentoo-a77db1ace19e04f6da7ac180cc035ccf567c0ff2.tar.gz
gentoo-a77db1ace19e04f6da7ac180cc035ccf567c0ff2.tar.bz2
gentoo-a77db1ace19e04f6da7ac180cc035ccf567c0ff2.zip
sys-libs/musl: version bump to 1.1.13
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-libs/musl')
-rw-r--r--sys-libs/musl/Manifest1
-rw-r--r--sys-libs/musl/files/musl-1.1.11-fix-codeset.patch12
-rw-r--r--sys-libs/musl/musl-1.1.12.ebuild4
-rw-r--r--sys-libs/musl/musl-1.1.13.ebuild128
-rw-r--r--sys-libs/musl/musl-9999.ebuild4
5 files changed, 133 insertions, 16 deletions
diff --git a/sys-libs/musl/Manifest b/sys-libs/musl/Manifest
index a4d38038c3f9..6b764e35e826 100644
--- a/sys-libs/musl/Manifest
+++ b/sys-libs/musl/Manifest
@@ -1 +1,2 @@
DIST musl-1.1.12.tar.gz 918757 SHA256 720b83c7e276b4b679c0bffe9509340d5f81fd601508e607e708177df0d31c0e SHA512 7cabbe2665e32bd3408c8865f89f474106e982b4e5de81d0cdeea19e19e20b4d2496faf1adc6b2811d996f30f39258184ba347e8eb5f3811eab89179e8f52d70 WHIRLPOOL cd500c3457be42d8dd927420d2352bda87e7b424fabf19fbd387858b913636793a7ff8d0e249bcc292e58c6d0d3889738c8790f3a6409d6df2da81408a77238c
+DIST musl-1.1.13.tar.gz 894640 SHA256 bbacdc64f557d0c4857f7d2daf592c32c29aec1babbb94fcf01a2e05bed15013 SHA512 d5f4a6fdb6a2cdbd7ab1ad5a8d91b1c690b3bd31d9049dfc022067019bba11952e375374eed982a0ddac7347d17f9ff2300178c4d5f27bdd8480933cc6e67802 WHIRLPOOL 4e419cebdb4deef4f0828d2b762783e40b1292048c6ba94ba70c48ef5277a1410fe1724ef242e8cab6db51e167e87496de3a8e7c4c016dcd17eadff8d3b3b7fe
diff --git a/sys-libs/musl/files/musl-1.1.11-fix-codeset.patch b/sys-libs/musl/files/musl-1.1.11-fix-codeset.patch
deleted file mode 100644
index e846f5f32a78..000000000000
--- a/sys-libs/musl/files/musl-1.1.11-fix-codeset.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur musl-1.1.11.orig/src/locale/langinfo.c musl-1.1.11/src/locale/langinfo.c
---- musl-1.1.11.orig/src/locale/langinfo.c 2015-08-30 00:15:56.000000000 -0400
-+++ musl-1.1.11/src/locale/langinfo.c 2015-09-08 15:46:26.717980251 -0400
-@@ -34,7 +34,7 @@
- const char *str;
-
- if (item == CODESET)
-- return MB_CUR_MAX==1 ? "UTF-8-CODE-UNITS" : "UTF-8";
-+ return "UTF-8";
-
- switch (cat) {
- case LC_NUMERIC:
diff --git a/sys-libs/musl/musl-1.1.12.ebuild b/sys-libs/musl/musl-1.1.12.ebuild
index 239a045a3676..574b31f421a1 100644
--- a/sys-libs/musl/musl-1.1.12.ebuild
+++ b/sys-libs/musl/musl-1.1.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,7 +18,7 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
-DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
+DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
HOMEPAGE="http://www.musl-libc.org/"
if [[ ${PV} != "9999" ]] ; then
PATCH_VER=""
diff --git a/sys-libs/musl/musl-1.1.13.ebuild b/sys-libs/musl/musl-1.1.13.ebuild
new file mode 100644
index 000000000000..e4804688a739
--- /dev/null
+++ b/sys-libs/musl/musl-1.1.13.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ inherit git-r3
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
+HOMEPAGE="http://www.musl-libc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER=""
+ SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~mips ~ppc ~x86"
+fi
+
+LICENSE="MIT LGPL-2 GPL-2"
+SLOT="0"
+IUSE="crosscompile_opts_headers-only"
+
+RDEPEND="!sys-apps/getent"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+just_headers() {
+ use crosscompile_opts_headers-only && is_crosscompile
+}
+
+musl_endian() {
+ # XXX: this wont work for bi-endian, but we dont have any
+ touch "${T}"/endian.s || die
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
+ case $(file "${T}"/endian.o) in
+ *" MSB "*) echo "";;
+ *" LSB "*) echo "el";;
+ *) echo "nfc";; # We shouldn't be here
+ esac
+}
+
+pkg_setup() {
+ if [ ${CTARGET} == ${CHOST} ] ; then
+ case ${CHOST} in
+ *-musl*) ;;
+ *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
+ esac
+ fi
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ tc-getCC ${CTARGET}
+ just_headers && export CC=true
+
+ local sysroot
+ is_crosscompile && sysroot=/usr/${CTARGET}
+ ./configure \
+ --target=${CTARGET} \
+ --prefix=${sysroot}/usr \
+ --syslibdir=${sysroot}/lib \
+ --disable-gcc-wrapper
+}
+
+src_compile() {
+ emake include/bits/alltypes.h
+ just_headers && return 0
+
+ emake
+}
+
+src_install() {
+ local target="install"
+ just_headers && target="install-headers"
+ emake DESTDIR="${D}" ${target}
+ just_headers && return 0
+
+ # musl provides ldd via a sym link to its ld.so
+ local sysroot
+ is_crosscompile && sysroot=/usr/${CTARGET}
+ local ldso=$(basename "${D}"${sysroot}/lib/ld-musl-*)
+ dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
+
+ if [[ ${CATEGORY} != cross-* ]] ; then
+ local target=$(tc-arch) arch
+ local endian=$(musl_endian)
+ case ${target} in
+ amd64) arch="x86_64";;
+ arm) arch="armhf";; # We only have hardfloat right now
+ mips) arch="mips${endian}";;
+ ppc) arch="powerpc";;
+ x86) arch="i386";;
+ esac
+ cp "${FILESDIR}"/ldconfig.in "${T}" || die
+ sed -e "s|@@ARCH@@|${arch}|" "${T}"/ldconfig.in > "${T}"/ldconfig || die
+ into /
+ dosbin "${T}"/ldconfig
+ into /usr
+ dobin "${FILESDIR}"/getent
+ echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00musl || die
+ doenvd "${T}"/00musl || die
+ fi
+}
+
+pkg_postinst() {
+ is_crosscompile && return 0
+
+ [ "${ROOT}" != "/" ] && return 0
+
+ ldconfig
+ # reload init ...
+ /sbin/telinit U 2>/dev/null
+}
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 016d210b7bdf..e4804688a739 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,7 +18,7 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
-DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
+DESCRIPTION="Light, fast and simple C library focused on standards-conformance and safety"
HOMEPAGE="http://www.musl-libc.org/"
if [[ ${PV} != "9999" ]] ; then
PATCH_VER=""