summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-23 14:55:23 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-23 15:14:07 -0400
commit6545c24e3a2a3f35fba4606ab278604e64666b61 (patch)
treef398527e63c73938c787e60a52aa02f9351ed5c7 /sys-libs/newlib/newlib-1.18.0.ebuild
parentx11-misc/albert: remove old (diff)
downloadgentoo-6545c24e3a2a3f35fba4606ab278604e64666b61.tar.gz
gentoo-6545c24e3a2a3f35fba4606ab278604e64666b61.tar.bz2
gentoo-6545c24e3a2a3f35fba4606ab278604e64666b61.zip
sys-libs/newlib: drop old <2.0.0 versions
Diffstat (limited to 'sys-libs/newlib/newlib-1.18.0.ebuild')
-rw-r--r--sys-libs/newlib/newlib-1.18.0.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/sys-libs/newlib/newlib-1.18.0.ebuild b/sys-libs/newlib/newlib-1.18.0.ebuild
deleted file mode 100644
index d68e30774120..000000000000
--- a/sys-libs/newlib/newlib-1.18.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils flag-o-matic toolchain-funcs
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="http://sourceware.org/newlib/"
-SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="nls threads unicode crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-NEWLIBBUILD="${WORKDIR}/build"
-
-pkg_setup() {
- # Reject newlib-on-glibc type installs
- if [[ ${CTARGET} == ${CHOST} ]] ; then
- case ${CHOST} in
- *-newlib|*-elf) ;;
- *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
- esac
- fi
-}
-
-src_unpack() {
- unpack ${A}
- mkdir -p "${NEWLIBBUILD}"
-}
-
-src_compile() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
-
- local myconf=""
- [[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-newlib-multithread" \
- || myconf="${myconf} $(use_enable threads newlib-multithread)"
-
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install || die
-# env -uRESTRICT CHOST=${CTARGET} prepallstrip
- # minor hack to keep things clean
- rm -fR "${D}"/usr/share/info
- rm -fR "${D}"/usr/info
-}