summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-23 07:47:35 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-23 07:48:45 +0100
commit25b326e873440a8bbb83a3734aeb6e839ef5d777 (patch)
tree91c6aa519661629321b2e309683383741564b075 /sys-libs/newlib/newlib-9999.ebuild
parentdev-ruby/rex-text: add 0.2.24 (diff)
downloadgentoo-25b326e873440a8bbb83a3734aeb6e839ef5d777.tar.gz
gentoo-25b326e873440a8bbb83a3734aeb6e839ef5d777.tar.bz2
gentoo-25b326e873440a8bbb83a3734aeb6e839ef5d777.zip
sys-libs/newlib: bump up to 3.1.0, bug #656018
Reported-by: David Flogeras Closes: https://bugs.gentoo.org/656018 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/newlib/newlib-9999.ebuild')
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
index 6575c24051a7..52ef720a87f4 100644
--- a/sys-libs/newlib/newlib-9999.ebuild
+++ b/sys-libs/newlib/newlib-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit flag-o-matic toolchain-funcs
@@ -10,9 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
- if [[ ${PV} != *.201[5-9]???? ]] ; then
- KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
- fi
+ KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
fi
export CBUILD=${CBUILD:-${CHOST}}
@@ -35,8 +33,12 @@ NEWLIBBUILD="${WORKDIR}/build"
NEWLIBNANOBUILD="${WORKDIR}/build.nano"
NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
-CFLAGS_FULL="-ffunction-sections -fdata-sections"
-CFLAGS_NANO="-Os -ffunction-sections -fdata-sections"
+# Adding -U_FORTIFY_SOURCE to conter the effect of Gentoo's
+# auto-addition of _FORTIFY_SOURCE at gcc site: bug #656018#c4
+# Currently newlib can't be built itself when _FORTIFY_SOURCE
+# is set.
+CFLAGS_FULL="-ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
+CFLAGS_NANO="-Os -ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
pkg_setup() {
# Reject newlib-on-glibc type installs