summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-01-19 12:16:22 -0800
committerAnthony G. Basile <blueness@gentoo.org>2017-01-21 08:38:38 -0500
commitfb978d6ac5116613ca421c01017758b23c8ffcce (patch)
tree5161027b2737b73f174129e5ae5d13b362cd02cc /sys-libs/obstack-standalone/obstack-standalone-1.1.ebuild
parentdev-perl/Sys-Virt: Bump to version 2.5.0 (diff)
downloadgentoo-fb978d6ac5116613ca421c01017758b23c8ffcce.tar.gz
gentoo-fb978d6ac5116613ca421c01017758b23c8ffcce.tar.bz2
gentoo-fb978d6ac5116613ca421c01017758b23c8ffcce.zip
sys-libs/obstack-standalone: New package
Diffstat (limited to 'sys-libs/obstack-standalone/obstack-standalone-1.1.ebuild')
-rw-r--r--sys-libs/obstack-standalone/obstack-standalone-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-libs/obstack-standalone/obstack-standalone-1.1.ebuild b/sys-libs/obstack-standalone/obstack-standalone-1.1.ebuild
new file mode 100644
index 000000000000..eea4e2b1aa3f
--- /dev/null
+++ b/sys-libs/obstack-standalone/obstack-standalone-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A standalone library to implement GNU libc's obstack."
+HOMEPAGE="https://github.com/pullmoll/musl-obstack"
+SRC_URI="https://github.com/pullmoll/musl-obstack/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc"
+
+S="${WORKDIR}/musl-obstack-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ mv "${ED%/}"/usr/$(get_libdir)/pkgconfig/{musl-obstack,obstack-standalone}.pc || die
+}