summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-11-25 21:42:48 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-11-25 21:44:29 +0300
commit269787f7426ebc351a10ef3e33598c9824506726 (patch)
tree0dd187aba51f5f579d205d85962cd248cf8a6eca /sys-libs/pam
parentmedia-fonts/ja-ipafonts: x86 stable (bug #749477) (diff)
downloadgentoo-269787f7426ebc351a10ef3e33598c9824506726.tar.gz
gentoo-269787f7426ebc351a10ef3e33598c9824506726.tar.bz2
gentoo-269787f7426ebc351a10ef3e33598c9824506726.zip
sys-libs/pam: vERSION BUMP (V1.5.1)
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-libs/pam')
-rw-r--r--sys-libs/pam/Manifest2
-rw-r--r--sys-libs/pam/pam-1.5.1.ebuild133
2 files changed, 135 insertions, 0 deletions
diff --git a/sys-libs/pam/Manifest b/sys-libs/pam/Manifest
index e327185d0060..6b743a697d83 100644
--- a/sys-libs/pam/Manifest
+++ b/sys-libs/pam/Manifest
@@ -1,4 +1,6 @@
DIST Linux-PAM-1.5.0-docs.tar.xz 441644 BLAKE2B 00dfefdc98cac438c2e4b3faff880b8c1d452884c40d70aa21182d33585b24a4dc98af1b4ec80c635c0659c4dca1b039b9b118a28bfb3f811c6025302fb3aff9 SHA512 d41027a8a19a944278ad22db6f8df3562188166eec135882f44503a64b69224336964b2129c8e895642af5b3f69221d0af21d8da3283098db395b8f8b64f5d4b
DIST Linux-PAM-1.5.0.tar.xz 972228 BLAKE2B f4baf22f391284f5ad04e1919f172827e57781561cc7e685b72ba37567639214ffb246aca408767b02ecfab964bbf2eea8667fd0a11ea83684ba6672c44c371e SHA512 27be57465371f86c101f93c15f4475e63867c02f8f5af40d3f83b2106bfc8a46b8079302214e17f198ef903dc35b72d00b0e9bdff63ed2ecd8c69543e278f4bf
+DIST Linux-PAM-1.5.1-docs.tar.xz 441632 BLAKE2B 1b3ad1b5167936b8c38977b5328ee11c7d280eb905a0f444e555d24f9d5332583f7e0ce0a758242292ff1244bc082b73d661935647e583e2ebcd8d5058df413e SHA512 95f0b0225e96386f06f5f869203163a201af3ac5c1a4fa8bd30779b9f55290e1a5b63fa49e2efafa1a51476bad1acf258b1f37f56a4bdc3935f9fe5928cbc1f7
+DIST Linux-PAM-1.5.1.tar.xz 972964 BLAKE2B a1714569587a383fa8211b23765c66b08b18dc2808c1521a904171dc2886cced56e9afa27408e8a9d5eec6226b31390dc8f14434071370f4e1147c77ce8b36ac SHA512 1db091fc43b934dde220f1b85f35937fbaa0a3feec699b2e597e2cdf0c3ce11c17d36d2286d479c9eed24e8ca3ca6233214e4dff256db47249e358c01d424837
DIST pam-doc-20201113.tar.gz 79239 BLAKE2B 40acf4460bff7f50874117765f47eaab3565dec31575f97772c42880cddd01f01f6143da39e8fc94e573916950e9662d500f5e8aa57f9283b9f46ee9862ddf2a SHA512 0a3bdbd8e88fc930ea1ab40634df65cca7694932c12e92dee64c7acc230039126c9567d5b76757ef64014a02fcc833428adb2c94da127032e4bd6a2c5376d3b7
DIST pam-e42e178c71c11bb25740a5177eed110ee17b8af2.tar.gz 810595 BLAKE2B 897f64a7f55c033601665b0ecc292cdcbd0d9b2f24199ed6ca5fc69c2da4da7401677493bed09a118b1fc0a475dc016fc7a3a318787c650212b056064ed0b817 SHA512 3c2bc401df51dbd4118698afc80a0448559bc6b5d8c7c45c800c2f6421034a131c0bee971f9640aec6b0d77f8a31ec055c7a84a646d9a11690dfda4af4e1068a
diff --git a/sys-libs/pam/pam-1.5.1.ebuild b/sys-libs/pam/pam-1.5.1.ebuild
new file mode 100644
index 000000000000..f9d428c8afbe
--- /dev/null
+++ b/sys-libs/pam/pam-1.5.1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="Linux-${PN^^}-${PV}"
+
+inherit autotools db-use fcaps toolchain-funcs usr-ldscript multilib-minimal
+
+DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
+HOMEPAGE="https://github.com/linux-pam/linux-pam"
+
+SRC_URI="https://github.com/linux-pam/linux-pam/releases/download/v${PV}/${MY_P}.tar.xz
+ https://github.com/linux-pam/linux-pam/releases/download/v${PV}/${MY_P}-docs.tar.xz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="audit berkdb debug nis +pie selinux"
+
+BDEPEND="
+ dev-libs/libxslt
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig
+ virtual/yacc
+"
+
+DEPEND="
+ virtual/libcrypt:=[${MULTILIB_USEDEP}]
+ >=virtual/libintl-0-r1[${MULTILIB_USEDEP}]
+ audit? ( >=sys-process/audit-2.2.2[${MULTILIB_USEDEP}] )
+ berkdb? ( >=sys-libs/db-4.8.30-r1:=[${MULTILIB_USEDEP}] )
+ selinux? ( >=sys-libs/libselinux-2.2.2-r4[${MULTILIB_USEDEP}] )
+ nis? ( net-libs/libnsl[${MULTILIB_USEDEP}]
+ >=net-libs/libtirpc-0.2.4-r2[${MULTILIB_USEDEP}] )"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND=">=sys-auth/pambase-20200616"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ touch ChangeLog || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # Do not let user's BROWSER setting mess us up. #549684
+ unset BROWSER
+
+ # Disable automatic detection of libxcrypt; we _don't_ want the
+ # user to link libxcrypt in by default, since we won't track the
+ # dependency and allow to break PAM this way.
+
+ export ac_cv_header_xcrypt_h=no
+
+ local myconf=(
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ --with-db-uniquename=-$(db_findver sys-libs/db)
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog
+ --enable-securedir="${EPREFIX}"/$(get_libdir)/security
+ --includedir="${EPREFIX}"/usr/include/security
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ --exec-prefix="${EPREFIX}"
+ --enable-unix
+ --disable-prelude
+ --disable-doc
+ --disable-regenerate-docu
+ --disable-static
+ --disable-Werror
+ $(use_enable audit)
+ $(use_enable berkdb db)
+ $(use_enable debug)
+ $(use_enable nis)
+ $(use_enable pie)
+ $(use_enable selinux)
+ --enable-isadir='.' #464016
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake sepermitlockdir="${EPREFIX}/run/sepermit"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install \
+ sepermitlockdir="${EPREFIX}/run/sepermit"
+
+ gen_usr_ldscript -a pam pam_misc pamc
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # tmpfiles.eclass is impossible to use because
+ # there is the pam -> tmpfiles -> systemd -> pam dependency loop
+
+ dodir /usr/lib/tmpfiles.d
+
+ cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}.conf <<-_EOF_
+ d /run/faillock 0755 root root
+ _EOF_
+ use selinux && cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}-selinux.conf <<-_EOF_
+ d /run/sepermit 0755 root root
+ _EOF_
+
+ local page
+
+ for page in doc/man/*.{3,5,8} modules/*/*.{5,8} ; do
+ doman ${page}
+ done
+}
+
+pkg_postinst() {
+ ewarn "Some software with pre-loaded PAM libraries might experience"
+ ewarn "warnings or failures related to missing symbols and/or versions"
+ ewarn "after any update. While unfortunate this is a limit of the"
+ ewarn "implementation of PAM and the software, and it requires you to"
+ ewarn "restart the software manually after the update."
+ ewarn ""
+ ewarn "You can get a list of such software running a command like"
+ ewarn " lsof / | egrep -i 'del.*libpam\\.so'"
+ ewarn ""
+ ewarn "Alternatively, simply reboot your system."
+
+ # The pam_unix module needs to check the password of the user which requires
+ # read access to /etc/shadow only.
+ fcaps cap_dac_override sbin/unix_chkpwd
+}