summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-10 00:28:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-25 17:18:14 +0100
commit9877ec6ae866ea500d69147b91c5e30208a0f63d (patch)
tree2303ca448c499cfde38b7d1ef9176139e141a835 /sys-libs/talloc
parentsys-libs/tdb: EAPI-7 bump, minor cleanup (diff)
downloadgentoo-9877ec6ae866ea500d69147b91c5e30208a0f63d.tar.gz
gentoo-9877ec6ae866ea500d69147b91c5e30208a0f63d.tar.bz2
gentoo-9877ec6ae866ea500d69147b91c5e30208a0f63d.zip
sys-libs/talloc: EAPI-7 bump, minor cleanup
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-libs/talloc')
-rw-r--r--sys-libs/talloc/talloc-2.3.1.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/sys-libs/talloc/talloc-2.3.1.ebuild b/sys-libs/talloc/talloc-2.3.1.ebuild
index b6befc83c907..849ee66f4691 100644
--- a/sys-libs/talloc/talloc-2.3.1.ebuild
+++ b/sys-libs/talloc/talloc-2.3.1.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="threads(+)"
-
inherit waf-utils python-single-r1 multilib multilib-minimal
DESCRIPTION="Samba talloc library"
@@ -18,8 +17,10 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 s
IUSE="compat +python"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
-RDEPEND="!elibc_FreeBSD? (
+RDEPEND="
+ !elibc_FreeBSD? (
!elibc_SunOS? (
!elibc_Darwin? (
dev-libs/libbsd[${MULTILIB_USEDEP}]
@@ -27,16 +28,16 @@ RDEPEND="!elibc_FreeBSD? (
)
)
python? ( ${PYTHON_DEPS} )
- !!<sys-libs/talloc-2.0.5"
-DEPEND="${RDEPEND}
- sys-devel/gettext
+ !!<sys-libs/talloc-2.0.5
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
dev-libs/libxslt
- ${PYTHON_DEPS}"
+ sys-devel/gettext
+"
WAF_BINARY="${S}/buildtools/bin/waf"
-RESTRICT="test"
-
MULTILIB_WRAPPED_HEADERS=(
# python goes only for native
/usr/include/pytalloc.h