summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-08 11:22:34 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-08 12:45:01 +0100
commit8f0290f51fa3922fc151712326ee7a31807546d8 (patch)
treef79fd7f49d9ae1f57f25d6fee2b4b96f9fff01d7 /sys-libs/tdb/tdb-1.3.12.ebuild
parentdev-libs/libunistring: Re-added $Id$ header line. (diff)
downloadgentoo-8f0290f51fa3922fc151712326ee7a31807546d8.tar.gz
gentoo-8f0290f51fa3922fc151712326ee7a31807546d8.tar.bz2
gentoo-8f0290f51fa3922fc151712326ee7a31807546d8.zip
sys-libs/tdb: Bump to version 1.3.12
Package-Manager: portage-2.3.3
Diffstat (limited to 'sys-libs/tdb/tdb-1.3.12.ebuild')
-rw-r--r--sys-libs/tdb/tdb-1.3.12.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-libs/tdb/tdb-1.3.12.ebuild b/sys-libs/tdb/tdb-1.3.12.ebuild
new file mode 100644
index 000000000000..6f54a5a44321
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.3.12.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}