summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-08-11 11:25:52 -0400
committerIan Stakenvicius <axs@gentoo.org>2017-08-11 17:23:02 -0400
commit216e7ef6531d5fe8c611fa7dae0011f0fc73c906 (patch)
tree8be94dcf3a5d2c3ffb301b7481aff8a6f7adaba5 /sys-libs/tevent/tevent-0.9.33.ebuild
parentapp-misc/away: EAPI 6 bump (diff)
downloadgentoo-216e7ef6531d5fe8c611fa7dae0011f0fc73c906.tar.gz
gentoo-216e7ef6531d5fe8c611fa7dae0011f0fc73c906.tar.bz2
gentoo-216e7ef6531d5fe8c611fa7dae0011f0fc73c906.zip
sys-libs/tevent-0.9.33: prevent bundling of talloc
If sys-libs/talloc is too old or is missing, tevent would build its own bundled copy. This commit prevents that from happening, causing a configuration error instead. This commit also addresses the configuration issue that hard requires pytalloc-util even when python is disabled (which was buried behind the bundling issue) Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-libs/tevent/tevent-0.9.33.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.9.33.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-libs/tevent/tevent-0.9.33.ebuild b/sys-libs/tevent/tevent-0.9.33.ebuild
index c454b5e965eb..fc46807e4d12 100644
--- a/sys-libs/tevent/tevent-0.9.33.ebuild
+++ b/sys-libs/tevent/tevent-0.9.33.ebuild
@@ -26,6 +26,10 @@ DEPEND="${RDEPEND}
# build system does not work with python3
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+PATCHES=(
+ "${FILESDIR}"/talloc-disable-python.patch
+)
+
WAF_BINARY="${S}/buildtools/bin/waf"
pkg_setup() {
@@ -39,6 +43,8 @@ src_prepare() {
multilib_src_configure() {
waf-utils_src_configure \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
$(multilib_native_usex python '' '--disable-python')
}