summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-13 15:35:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-13 16:13:42 +0200
commit4d033344e6ccade0c1e69a0a5af1b8e8573d0df7 (patch)
tree17d6edd394554ba06939ebdc56abec1520aebc4f /sys-libs/tevent/tevent-0.9.37.ebuild
parentsys-libs/talloc: Removed old. (diff)
downloadgentoo-4d033344e6ccade0c1e69a0a5af1b8e8573d0df7.tar.gz
gentoo-4d033344e6ccade0c1e69a0a5af1b8e8573d0df7.tar.bz2
gentoo-4d033344e6ccade0c1e69a0a5af1b8e8573d0df7.zip
sys-libs/tevent: Bump to version 0.9.37
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'sys-libs/tevent/tevent-0.9.37.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.9.37.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-libs/tevent/tevent-0.9.37.ebuild b/sys-libs/tevent/tevent-0.9.37.ebuild
new file mode 100644
index 000000000000..535a4e4d864f
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.37.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="https://tevent.samba.org/"
+SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="elibc_glibc python"
+
+RDEPEND=">=sys-libs/talloc-2.1.13[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ elibc_glibc? (
+ net-libs/libtirpc[${MULTILIB_USEDEP}]
+ || (
+ net-libs/rpcsvc-proto
+ <sys-libs/glibc-2.26[rpc(+)]
+ )
+ )
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}