summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-16 14:41:34 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-16 16:04:44 +0100
commit312686c88a21562238b56149626fc74ffaebf7c3 (patch)
treeaf61ef2505b02bf5c5a02bfae3bf367ddd5e34c7 /sys-libs/tevent
parentsys-libs/talloc: Bump to version 2.1.11 (diff)
downloadgentoo-312686c88a21562238b56149626fc74ffaebf7c3.tar.gz
gentoo-312686c88a21562238b56149626fc74ffaebf7c3.tar.bz2
gentoo-312686c88a21562238b56149626fc74ffaebf7c3.zip
sys-libs/tevent: Bump to version 0.9.35
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/Manifest1
-rw-r--r--sys-libs/tevent/tevent-0.9.35.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index aa0755d363ec..675d6b8f7f6a 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -3,3 +3,4 @@ DIST tevent-0.9.31.tar.gz 587784 BLAKE2B 0e562600ae8ba4dae194b1a28a020f5618b1566
DIST tevent-0.9.32.tar.gz 590314 BLAKE2B 6159d2eac6ea49814fa83b982176db58fad6a9b619a28145bcee3eaff6b294559bcd863f2a3c8336cb218b8978145457d6dcf9e1af2239298d3811413f2bee69 SHA512 9bd256c245d9f82dcd5b31787c8b11780b958bef96426de231f54eaea6df680a5cf3eb8c8d066d05f271e81f303404fc4191a23a6bc2533b7d1b732b2c206fbd
DIST tevent-0.9.33.tar.gz 590611 BLAKE2B 087cd196b5cd0ca675280ce35d2a3f51a69d3e36f3ca99be0860873b0078fa4b94092731e2d23c15e8ad0db9703735ee07b90a1900e27245295f11edb3798e6d SHA512 3a437957859a556e06f24334301c41a3db1433c1e90d651fa74585a638a36d71369f235a8ab51aa0dd8f9d9bb88ad42f2c3ddeba0b99c4234c63866a8c922b91
DIST tevent-0.9.34.tar.gz 590260 BLAKE2B 7acd5b5ec540ab97641729e2b6300335a581d70ae2a76d0a93959c47cf84109cb1f52234b7189ecdd28390205b828296bbbde0820e9ba23a7bb33677b347a584 SHA512 29ff88cedc05d9345749ee241f8ab083fc6f98d3975b2739629a3a75a766db6ec42133eeb6c9297315ee0c68ab512c70b8b927d2df5ea61880c673ef33b44183
+DIST tevent-0.9.35.tar.gz 591546 BLAKE2B d0df81dc1998ae5806f3f8b613c5640af56d52c0e6fdea8f57c95cf4ef5d8bf349992582b97da94cbcc048bc3f758ecb03e836847467588e7dbfbb1aef87b906 SHA512 935719382469a0f39764a7ebdbc0ee977ccca2fc55ff1e896ddd95ba2d065d989f0c366cb98be95ce87475e628b0de38b7138261717a5c2cee870e98339ed5fd
diff --git a/sys-libs/tevent/tevent-0.9.35.ebuild b/sys-libs/tevent/tevent-0.9.35.ebuild
new file mode 100644
index 000000000000..c2a8eb8ad787
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.35.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="https://tevent.samba.org/"
+SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.11[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+#PATCHES=(
+# "${FILESDIR}"/talloc-disable-python.patch
+#)
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}
+
+multilib_src_install_all() {
+ insinto /usr/include
+ doins tevent_internal.h
+}