summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-23 15:26:32 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-23 15:26:32 +0100
commit5036cd55e8dc0287605350486047b58647b9feeb (patch)
tree38e7b4040981c542adc63064db405d52f77b0e3f /sys-libs/tevent
parentsci-mathematics/yafu: Add openmp dependency (diff)
downloadgentoo-5036cd55e8dc0287605350486047b58647b9feeb.tar.gz
gentoo-5036cd55e8dc0287605350486047b58647b9feeb.tar.bz2
gentoo-5036cd55e8dc0287605350486047b58647b9feeb.zip
sys-libs/tevent: add missing `#include <sys/types.h>`
Closes: https://bugs.gentoo.org/828720 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/files/tevent-0.11.0-missing-include.patch13
-rw-r--r--sys-libs/tevent/tevent-0.11.0.ebuild2
2 files changed, 15 insertions, 0 deletions
diff --git a/sys-libs/tevent/files/tevent-0.11.0-missing-include.patch b/sys-libs/tevent/files/tevent-0.11.0-missing-include.patch
new file mode 100644
index 000000000000..c88550e54e64
--- /dev/null
+++ b/sys-libs/tevent/files/tevent-0.11.0-missing-include.patch
@@ -0,0 +1,13 @@
+pid_t requires <sys/types.h>
+Bug: https://bugs.gentoo.org/828720
+
+--- a/tevent.h
++++ b/tevent.h
+@@ -31,6 +31,7 @@
+ #include <stdint.h>
+ #include <talloc.h>
+ #include <sys/time.h>
++#include <sys/types.h>
+ #include <stdbool.h>
+
+ /* for old gcc releases that don't have the feature test macro __has_attribute */
diff --git a/sys-libs/tevent/tevent-0.11.0.ebuild b/sys-libs/tevent/tevent-0.11.0.ebuild
index 4190931690f9..145c572a0a4b 100644
--- a/sys-libs/tevent/tevent-0.11.0.ebuild
+++ b/sys-libs/tevent/tevent-0.11.0.ebuild
@@ -41,6 +41,8 @@ BDEPEND="${PYTHON_DEPS}
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}"/${P}-missing-include.patch )
+
WAF_BINARY="${S}/buildtools/bin/waf"
pkg_setup() {