summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/zlib/zlib-1.2.3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/zlib/zlib-1.2.3-r1.ebuild')
-rw-r--r--sys-libs/zlib/zlib-1.2.3-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/sys-libs/zlib/zlib-1.2.3-r1.ebuild b/sys-libs/zlib/zlib-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..ffbe7730e630
--- /dev/null
+++ b/sys-libs/zlib/zlib-1.2.3-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Standard (de)compression library"
+HOMEPAGE="http://www.zlib.net/"
+SRC_URI="http://www.gzip.org/zlib/${P}.tar.bz2
+ http://www.zlib.net/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-visibility-support.patch #149929
+ epatch "${FILESDIR}"/${PN}-1.2.1-glibc.patch
+ epatch "${FILESDIR}"/${PN}-1.2.1-build-fPIC.patch
+ epatch "${FILESDIR}"/${PN}-1.2.1-configure.patch #55434
+ epatch "${FILESDIR}"/${PN}-1.2.1-fPIC.patch
+ epatch "${FILESDIR}"/${PN}-1.2.3-r1-bsd-soname.patch #123571
+ epatch "${FILESDIR}"/${PN}-1.2.3-LDFLAGS.patch #126718
+ epatch "${FILESDIR}"/${PN}-1.2.3-mingw-implib.patch #288212
+ sed -i -e '/ldconfig/d' Makefile*
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ export RC=${CHOST}-windres DLLWRAP=${CHOST}-dllwrap
+ emake -f win32/Makefile.gcc prefix=/usr || die
+ ;;
+ *)
+ # not an autoconf script, so cant use econf
+ ./configure --shared --prefix=/usr --libdir=/$(get_libdir) || die
+ emake || die
+ ;;
+ esac
+}
+
+src_install() {
+ einstall libdir="${D}"/$(get_libdir) || die
+ rm "${D}"/$(get_libdir)/libz.a
+ insinto /usr/include
+ doins zconf.h zlib.h
+
+ doman zlib.3
+ dodoc FAQ README ChangeLog algorithm.txt
+
+ # we don't need the static lib in /lib
+ # as it's only for compiling against
+ dolib libz.a
+
+ # all the shared libs go into /lib
+ # for NFS based /usr
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ dobin zlib1.dll || die
+ dolib libz.dll.a || die
+ ;;
+ *)
+ into /
+ dolib libz.so.${PV}
+ ( cd "${D}"/$(get_libdir) ; chmod 755 libz.so.* )
+ dosym libz.so.${PV} /$(get_libdir)/libz.so
+ dosym libz.so.${PV} /$(get_libdir)/libz.so.1
+ gen_usr_ldscript libz.so
+ ;;
+ esac
+}