summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-31 10:48:51 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-31 22:48:06 +0100
commit00ed64aebc52061bedaaf0511b041f388315beb9 (patch)
treeb0dcdb72287da009e4c661f951e13a7fc4c37604 /sys-libs
parentnet-libs/ldns: stable 1.7.0-r2 for hppa, bug #509632 (diff)
downloadgentoo-00ed64aebc52061bedaaf0511b041f388315beb9.tar.gz
gentoo-00ed64aebc52061bedaaf0511b041f388315beb9.tar.bz2
gentoo-00ed64aebc52061bedaaf0511b041f388315beb9.zip
sys-libs/ncurses: Stop using awful multijob_* logic
The multijob logic adds a lot of complex, unmaintained and fragile bash code with little gain. Moreover, makes build logs unreadable by interspersing output from multiple configure runs. Bug: https://bugs.gentoo.org/613322
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ncurses-5.9-r101.ebuild11
-rw-r--r--sys-libs/ncurses/ncurses-6.0-r1.ebuild9
2 files changed, 7 insertions, 13 deletions
diff --git a/sys-libs/ncurses/ncurses-5.9-r101.ebuild b/sys-libs/ncurses/ncurses-5.9-r101.ebuild
index 76b8a76d3a72..c722d68f3208 100644
--- a/sys-libs/ncurses/ncurses-5.9-r101.ebuild
+++ b/sys-libs/ncurses/ncurses-5.9-r101.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# This version is just for the ABI .5 library
EAPI="5"
-inherit eutils toolchain-funcs multilib-minimal multiprocessing
+inherit eutils toolchain-funcs multilib-minimal
MY_PV=${PV:0:3}
MY_P=${PN}-${MY_PV}
@@ -55,8 +55,6 @@ src_configure() {
$(usex unicode 'ncursesw' '')
)
- multijob_init
-
# When installing ncurses, we have to use a compatible version of tic.
# This comes up when cross-compiling, doing multilib builds, upgrading,
# or installing for the first time. Build a local copy of tic whenever
@@ -69,16 +67,15 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} -static" \
- multijob_child_init do_configure cross --without-shared --with-normal
+ do_configure cross --without-shared --with-normal
fi
multilib-minimal_src_configure
- multijob_finish
}
multilib_src_configure() {
local t
for t in "${NCURSES_TARGETS[@]}" ; do
- multijob_child_init do_configure "${t}"
+ do_configure "${t}"
done
}
diff --git a/sys-libs/ncurses/ncurses-6.0-r1.ebuild b/sys-libs/ncurses/ncurses-6.0-r1.ebuild
index 2ab63de41d4c..d98b23afb751 100644
--- a/sys-libs/ncurses/ncurses-6.0-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-6.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit eutils flag-o-matic toolchain-funcs multilib-minimal multiprocessing
+inherit eutils flag-o-matic toolchain-funcs multilib-minimal
MY_PV=${PV:0:3}
PV_SNAP=${PV:4}
@@ -61,8 +61,6 @@ src_configure() {
$(use unicode && usex threads 'ncursestw' '')
)
- multijob_init
-
# When installing ncurses, we have to use a compatible version of tic.
# This comes up when cross-compiling, doing multilib builds, upgrading,
# or installing for the first time. Build a local copy of tic whenever
@@ -87,16 +85,15 @@ src_configure() {
CXXFLAGS=${BUILD_CXXFLAGS} \
CPPFLAGS=${BUILD_CPPFLAGS} \
LDFLAGS="${BUILD_LDFLAGS} ${lbuildflags}" \
- multijob_child_init do_configure cross --without-shared --with-normal
+ do_configure cross --without-shared --with-normal
fi
multilib-minimal_src_configure
- multijob_finish
}
multilib_src_configure() {
local t
for t in "${NCURSES_TARGETS[@]}" ; do
- multijob_child_init do_configure "${t}"
+ do_configure "${t}"
done
}