summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 00:56:57 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:18 -0700
commit01cd7e88a2e71e5e31375f2ab79c60f1303d7f00 (patch)
tree41893694386a2deb5e3f52ef4443d43a709c6c7c /sys-libs
parentsys-libs/libsepol: Version updated to 3.2. (diff)
downloadgentoo-01cd7e88a2e71e5e31375f2ab79c60f1303d7f00.tar.gz
gentoo-01cd7e88a2e71e5e31375f2ab79c60f1303d7f00.tar.bz2
gentoo-01cd7e88a2e71e5e31375f2ab79c60f1303d7f00.zip
sys-libs/libsepol: Sync live ebuild.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libsepol/libsepol-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/sys-libs/libsepol/libsepol-9999.ebuild b/sys-libs/libsepol/libsepol-9999.ebuild
index 5b122e23e551..b175e9bfb3a4 100644
--- a/sys-libs/libsepol/libsepol-9999.ebuild
+++ b/sys-libs/libsepol/libsepol-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit multilib toolchain-funcs multilib-minimal
-MY_P="${P//_/-}"
-MY_RELEASEDATE="20200710"
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
DESCRIPTION="SELinux binary policy representation library"
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
@@ -14,15 +14,15 @@ HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN}"
+ S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
S="${WORKDIR}/${MY_P}"
fi
LICENSE="GPL-2"
-SLOT="0"
+SLOT="0/2"
IUSE=""
DEPEND=""
@@ -39,8 +39,7 @@ src_prepare() {
multilib_src_compile() {
tc-export CC AR RANLIB
- # https://bugs.gentoo.org/706730
- local -x CFLAGS="${CFLAGS} -fcommon"
+ local -x CFLAGS="${CFLAGS} -fno-semantic-interposition"
emake \
LIBDIR="\$(PREFIX)/$(get_libdir)" \