summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-03-08 20:08:14 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-03-08 22:23:36 +0100
commit0aa43807593cf9fdf35613649b970dbe9b840d93 (patch)
tree686eda93945089de4239819339d6b959de5b393a /sys-libs
parentnet-dns/resolv_wrapper: Initial commit. (diff)
downloadgentoo-0aa43807593cf9fdf35613649b970dbe9b840d93.tar.gz
gentoo-0aa43807593cf9fdf35613649b970dbe9b840d93.tar.bz2
gentoo-0aa43807593cf9fdf35613649b970dbe9b840d93.zip
sys-libs/talloc: Bump to version 2.1.6
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/talloc/Manifest1
-rw-r--r--sys-libs/talloc/talloc-2.1.6.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-libs/talloc/Manifest b/sys-libs/talloc/Manifest
index 6cc48ec371c6..6c219c77b9e9 100644
--- a/sys-libs/talloc/Manifest
+++ b/sys-libs/talloc/Manifest
@@ -1,3 +1,4 @@
DIST talloc-2.1.0.tar.gz 416097 SHA256 0701393882647f823503e3aa075bc67d75c194b376822377dae2d20f9130f08f SHA512 7bdc448c91211299edf16502d263362ac660d5123d8ea7bb2ed58af2231537e4f29da5384b8d5be10254a02b193520890e95a73d697c40eba09728a9b6d56d57 WHIRLPOOL d8593cba27f5d971acb39acacdbea70df5b80ed31288cf440a2ebeaca266e070deeea8322f4ba5682580f66044128f18dd6d76b735aa0670aed46f13f5a4e857
DIST talloc-2.1.4.tar.gz 436552 SHA256 aea04697a28d809054fb59c4c0b94912757037981dedbec1be47d09fe10749b3 SHA512 723f5b78f91ca873c8f79aee714428dfc3cfabbb65ac1eff3364d5ac6ded7fe5fc03d78dfc3b6c329d37e277e431a75b634f3c30485b33704a6d25f56379ad8f WHIRLPOOL 6bdef24de13d207c4b8f1ee9a2a5f4586d8aa4c3e97e3d6d746bfe69c865257b2a18b4598abc5189b3eb2e89e4e2ad0f328dd69f187b52cdffb3f82214eb8466
DIST talloc-2.1.5.tar.gz 436193 SHA256 3833e750cf0b8c3439186cba38800cba9e26adfbce10ee98ba709c24eb1cdddd SHA512 b938d67fcf4c6618f1149b4ec665957a604e3b07ee26e96ed36d94312db8f56b50498f69f9a07782f7f10a25047604e32b0d1786e1051d5f36b696c2755f8741 WHIRLPOOL 4cbdd527fb1adfe09052b93b38227f6e01f8aa86920aa093b7aa9a0ca63ad03f1ddcc148c996c487c55b1ba6e681b185d1df0311ed388ef9a8e6ab35c4b111ab
+DIST talloc-2.1.6.tar.gz 436983 SHA256 3b8e1a50bacb359d99942e0dd9941cef779ae4b5eb20f138873bd8270cb1d47b SHA512 d872780d7ea13757ddb5640c0de5d5c013a9669d07820e9f95b32c460854a4d9327501816a210f33db434b69218a266a6532d5b89fcb6ca84ede90908e3f95c6 WHIRLPOOL 875424e1f84fe28d14b9272758f751ca4c75a38c4fab728f5f8beb1f35052c4f8abfa2a67856120136ea8f9b78d58339e9114f16998c710dfec919b43fe320aa
diff --git a/sys-libs/talloc/talloc-2.1.6.ebuild b/sys-libs/talloc/talloc-2.1.6.ebuild
new file mode 100644
index 000000000000..ed4832eaec1b
--- /dev/null
+++ b/sys-libs/talloc/talloc-2.1.6.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils python-single-r1 multilib multilib-minimal
+
+DESCRIPTION="Samba talloc library"
+HOMEPAGE="http://talloc.samba.org/"
+SRC_URI="http://samba.org/ftp/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3+ LGPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~sparc-solaris"
+IUSE="compat +python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ !!<sys-libs/talloc-2.0.5
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r1
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-libs/libxslt
+ ${PYTHON_DEPS}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+RESTRICT="test"
+
+MULTILIB_WRAPPED_HEADERS=(
+ # python goes only for native
+ /usr/include/pytalloc.h
+)
+
+pkg_setup() {
+ # try to turn off distcc and ccache for people that have a problem with it
+ export DISTCC_DISABLE=1
+ export CCACHE_DISABLE=1
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # what would you expect of waf? i won't even waste time trying.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+
+ use compat && extra_opts+=( --enable-talloc-compat1 )
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ # waf is stupid, and no, we can't fix the build-system, since it's provided
+ # as a brilliant binary blob thats decompressed on the fly
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libtalloc.2.0.5.dylib || die
+ if use python ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libpytalloc-util.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
+ install_name_tool \
+ -change "${S}/bin/default/libtalloc.dylib" \
+ "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
+ install_name_tool \
+ -change "${S}/bin/default/libtalloc.dylib" \
+ "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${D}"$(python_get_sitedir)/talloc.bundle || die
+ fi
+ fi
+}