summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 18:56:03 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-03 12:46:18 +0100
commit1447f6b293b1f20ecc721a4e4b4a4eb3c5d00eba (patch)
treedc5cbfb0661810bfaf9fe3e1986ad7856b7a05d5 /sys-libs
parentdev-util/lldb: Port to llvm.org eclass (diff)
downloadgentoo-1447f6b293b1f20ecc721a4e4b4a4eb3c5d00eba.tar.gz
gentoo-1447f6b293b1f20ecc721a4e4b4a4eb3c5d00eba.tar.bz2
gentoo-1447f6b293b1f20ecc721a4e4b4a4eb3c5d00eba.zip
sys-libs/compiler-rt: Port to llvm.org eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild12
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild7
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild13
3 files changed, 9 insertions, 23 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
index fee62ad9c75a..1c0ee0530aff 100644
--- a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
@@ -4,14 +4,13 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
+inherit cmake-utils flag-o-matic llvm llvm.org multiprocessing \
python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-S=${WORKDIR}/${P}/compiler-rt
+LLVM_COMPONENTS=( compiler-rt )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
@@ -45,11 +44,6 @@ pkg_setup() {
python-any-r1_pkg_setup
}
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' compiler-rt
-}
-
test_compiler() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
<<<'int main() { return 0; }' &>/dev/null
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild
index 658306b72f46..ed72a058928f 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild
@@ -4,14 +4,13 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils flag-o-matic llvm multiprocessing \
+inherit cmake-utils flag-o-matic llvm llvm.org multiprocessing \
python-any-r1 toolchain-funcs
-MY_P=${P}.src
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
-S=${WORKDIR}/${MY_P}
+LLVM_COMPONENTS=( compiler-rt )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
index 1d00f77cdca7..1c0ee0530aff 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.1.9999.ebuild
@@ -4,15 +4,13 @@
EAPI=7
PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
+inherit cmake-utils flag-o-matic llvm llvm.org multiprocessing \
python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
-EGIT_BRANCH="release/9.x"
-S=${WORKDIR}/${P}/compiler-rt
+LLVM_COMPONENTS=( compiler-rt )
+llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
@@ -46,11 +44,6 @@ pkg_setup() {
python-any-r1_pkg_setup
}
-src_unpack() {
- git-r3_fetch
- git-r3_checkout '' '' '' compiler-rt
-}
-
test_compiler() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
<<<'int main() { return 0; }' &>/dev/null