summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-21 19:00:39 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-21 22:00:59 +0100
commit189fee09cf72bf4eb18647a0fb599b2d12091490 (patch)
tree6100cd5560f208742bd68fce01b2def4d2c48433 /sys-libs
parentsys-libs/llvm-libunwind: Remove live ebuild for obsolete 5.0 branch (diff)
downloadgentoo-189fee09cf72bf4eb18647a0fb599b2d12091490.tar.gz
gentoo-189fee09cf72bf4eb18647a0fb599b2d12091490.tar.bz2
gentoo-189fee09cf72bf4eb18647a0fb599b2d12091490.zip
sys-libs/libcxxabi: Remove live ebuild for obsolete 5.0 branch
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-5.0.9999.ebuild97
1 files changed, 0 insertions, 97 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-5.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-5.0.9999.ebuild
deleted file mode 100644
index e0e65a32002c..000000000000
--- a/sys-libs/libcxxabi/libcxxabi-5.0.9999.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-multilib git-r3 llvm python-any-r1
-
-DESCRIPTION="Low level support for a standard C++ library"
-HOMEPAGE="https://libcxxabi.llvm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libcxxabi.git
- https://github.com/llvm-mirror/libcxxabi.git"
-EGIT_BRANCH="release_50"
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-KEYWORDS=""
-IUSE="+libunwind +static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- libunwind? (
- || (
- >=sys-libs/libunwind-1.0.1-r1[static-libs?,${MULTILIB_USEDEP}]
- >=sys-libs/llvm-libunwind-3.9.0-r1[static-libs?,${MULTILIB_USEDEP}]
- )
- )"
-# LLVM 4 required for llvm-config --cmakedir
-DEPEND="${RDEPEND}
- >=sys-devel/llvm-4
- test? ( >=sys-devel/clang-3.9.0
- ~sys-libs/libcxx-${PV}[libcxxabi(-)]
- $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )"
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-python_check_deps() {
- has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- llvm_pkg_setup
- use test && python-any-r1_pkg_setup
-}
-
-src_unpack() {
- # we need the headers
- git-r3_fetch "https://git.llvm.org/git/libcxx.git
- https://github.com/llvm-mirror/libcxx.git"
- git-r3_fetch
-
- git-r3_checkout https://llvm.org/git/libcxx.git \
- "${WORKDIR}"/libcxx '' include utils/libcxx
- git-r3_checkout
-}
-
-multilib_src_configure() {
- local libdir=$(get_libdir)
- local mycmakeargs=(
- -DLIBCXXABI_LIBDIR_SUFFIX=${libdir#lib}
- -DLIBCXXABI_ENABLE_SHARED=ON
- -DLIBCXXABI_ENABLE_STATIC=$(usex static-libs)
- -DLIBCXXABI_USE_LLVM_UNWINDER=$(usex libunwind)
- -DLIBCXXABI_INCLUDE_TESTS=$(usex test)
-
- -DLIBCXXABI_LIBCXX_INCLUDES="${WORKDIR}"/libcxx/include
- # upstream is omitting standard search path for this
- # probably because gcc & clang are bundling their own unwind.h
- -DLIBCXXABI_LIBUNWIND_INCLUDES="${EPREFIX}"/usr/include
- )
- if use test; then
- mycmakeargs+=(
- -DLIT_COMMAND="${EPREFIX}"/usr/bin/lit
- )
- fi
- cmake-utils_src_configure
-}
-
-multilib_src_test() {
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
-
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
- sed -i -e "/cxx_under_test/s^\".*\"^\"${clang_path}\"^" test/lit.site.cfg || die
-
- cmake-utils_src_make check-libcxxabi
-}
-
-multilib_src_install_all() {
- insinto /usr/include/libcxxabi
- doins -r include/.
-}