summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-19 10:08:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-19 10:09:13 +0200
commit249b821bb8161c2e795fd8fc086721695bd4e6d9 (patch)
treee315a07662867603bdf361a28966d33894c0f220 /sys-libs
parentsci-calculators/wcalc: Version bump to 2.5 / EAPI bump 4 -> 6 (diff)
downloadgentoo-249b821bb8161c2e795fd8fc086721695bd4e6d9.tar.gz
gentoo-249b821bb8161c2e795fd8fc086721695bd4e6d9.tar.bz2
gentoo-249b821bb8161c2e795fd8fc086721695bd4e6d9.zip
sys-libs/tevent: Bump to version 0.9.31
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tevent/Manifest1
-rw-r--r--sys-libs/tevent/tevent-0.9.31.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index 5873a71b99ae..26d57a6e35d4 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -2,3 +2,4 @@ DIST tevent-0.9.26.tar.gz 581664 SHA256 262c14d78ede13f2c4fc5e61485ae7250a201782
DIST tevent-0.9.28.tar.gz 581522 SHA256 04d953379025b1560af5c4ffcce58a3ee84db7aaa09c9f1e3eff5b2945a13529 SHA512 328d586a5891796a731e6f0d02e1a731d3541a977c16abca355359cd7f60bbdbb0baaad49c05eb42c3a44f97e57a775605974d22d46ca6c26f283c8ca1b5a909 WHIRLPOOL 3a572a1c73d564b535b15fca06a1df1ba124cac031026a1cabcbc66e38cac374eb8dad05a25372ab66982ff3c772ed63e890b62545dcce926fa782fe5fc21147
DIST tevent-0.9.29.tar.gz 584544 SHA256 a4f519b0bbb718fe2175bee9011ee4d199675f28c2ef80531be38e7bbaa1c42b SHA512 831289664d3ad22ac3e1a153e0433a583c4a090cd31e25ea7afc5d974c39c1fe5d36784ff5cfffcce344df69a0852a4098834abadfab8d723fe6b6d0d8e91594 WHIRLPOOL 23e6df7158747ee2ae702a3198d0c2716668242d795692bc5bb6ddaf9ff681c423e0026fb78dd3f4f13ac46ec352001e65147bd398eade4ab67f6aab6d23f339
DIST tevent-0.9.30.tar.gz 587303 SHA256 5785915e6f76a8a7f7251055be1cef7a7465150a2f63d893082a1ab762c48cbd SHA512 bf3509cbddcc6a36b29cec3a7e5eb6699272a1b7dc66ccd7219e8c1b8daa591d886ac6bd77b35029f45b9e1e1bbe949fbb74ad5b3ddb684e886949f7d4103b1e WHIRLPOOL 83ac49438ce9a8092d97ae1315718cb6ed6c26d9abee5768eda47cdf92995576b1342553e793f61f1b2bf2fec684f142885f30a6f374c31c6c5ad94ddb39d717
+DIST tevent-0.9.31.tar.gz 587784 SHA256 4a13f2256ad804c860e84068258bd0f8be31cf0c79aa8f3019fa32f6928c2bfc SHA512 048e37a7f5d3b8e948215fdb909c9b6e94b915c9d4978a8e18c73c9d27d5b1f179c10d19ec90325f8250e7c177c28231ad116a2975caaa43312c383e75517258 WHIRLPOOL 44061dd68b284bcaef625a70769f472ff1f2bd509843f8da9aca3c7b5affa12a825d3df49f126edc2d883bc0b1ad10eb59fba75ad80b1db12c92aeb100701fcd
diff --git a/sys-libs/tevent/tevent-0.9.31.ebuild b/sys-libs/tevent/tevent-0.9.31.ebuild
new file mode 100644
index 000000000000..ba458c3831f0
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.31.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.8[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}