summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-05-14 00:48:07 +0800
committerJason Zaman <perfinion@gentoo.org>2018-05-14 01:28:11 +0800
commit4c055333636a67e891d2e9b5448054c55fc8dc43 (patch)
tree6ad68393f2a6a43054c6aa1804b7d29b68b9c5a8 /sys-libs
parentsys-libs/libsepol: bump to 2.8_rc3 (diff)
downloadgentoo-4c055333636a67e891d2e9b5448054c55fc8dc43.tar.gz
gentoo-4c055333636a67e891d2e9b5448054c55fc8dc43.tar.bz2
gentoo-4c055333636a67e891d2e9b5448054c55fc8dc43.zip
sys-libs/libselinux: bump to 2.8_rc3
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libselinux/Manifest1
-rw-r--r--sys-libs/libselinux/libselinux-2.8_rc3.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/sys-libs/libselinux/Manifest b/sys-libs/libselinux/Manifest
index 6ad9ab643b4d..c2940ad189a1 100644
--- a/sys-libs/libselinux/Manifest
+++ b/sys-libs/libselinux/Manifest
@@ -2,3 +2,4 @@ DIST libselinux-2.6.tar.gz 203119 BLAKE2B ee18d11258e8ea1611d46b5c748bd972084809
DIST libselinux-2.7.tar.gz 187574 BLAKE2B cc6ee51d5015943dd73fe16efb2ce2478616f43eaf7da55655de50502010e69973c2de13c8a562c8814a31211a8dbd7200fa2f22761f3d0f81fa3a1d3cd1e998 SHA512 415d10306692d4323455b61fb61d7e56e53b9144276ff206d72760e1df9b04ab07c62a4d6f04bf4e5fa708f9f14b21a9801069b16ece0a0aade886950941ab8d
DIST libselinux-2.8-rc1.tar.gz 187670 BLAKE2B b3ea4c32571a78fd535c4144487a5ceb83ab74642fec89effaec992f467b7ed3efd899487173a9b0ebb898b369cc2dadab8add38e27093beab85d21ca0b47e75 SHA512 11f51348d1b743e82b5c01abed4664b3513295436bec109e414df1ed86334422e294109c9563e6552ecab0d16e23c2fb3ea5f420f6ba3f11d35be1d9c8d20477
DIST libselinux-2.8-rc2.tar.gz 187700 BLAKE2B 51ce916fc40fc8d551f3578d6eff87a53442e75644cb9877aa68e85d7db63057d3c33bb7a860fcb13d0fd094c23c024f9d6668ce6ff9d4294d380b0e5f71519d SHA512 052b86ba717820b482df056de69ce225090f39974b6fcc06d50d669601339deaeb2b507f7c1a18a614edee036e75a0ee59108742bd97fe78d19dda9afcdadf52
+DIST libselinux-2.8-rc3.tar.gz 187741 BLAKE2B 55b3df4386fa096fd7437c999a8eeb9623b8101dfced78033fbcb494017d02944864fd0d6fed0746e143c2507ce0c309bf6942ca13b70848d9bc969cbe2a17df SHA512 2b0bf8790fe8d8c87613542fe7618352dd195e2fe75a9d50c15851e48442a18adb59d65b8e9316ad6d044f57f1359d23215696ee5972019a9e4e812bf42fecbe
diff --git a/sys-libs/libselinux/libselinux-2.8_rc3.ebuild b/sys-libs/libselinux/libselinux-2.8_rc3.ebuild
new file mode 100644
index 000000000000..9863dc6abb00
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-2.8_rc3.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+USE_RUBY="ruby23"
+
+# No, I am not calling ruby-ng
+inherit multilib python-r1 toolchain-funcs multilib-minimal
+
+MY_P="${P//_/-}"
+SEPOL_VER="${PV}"
+MY_RELEASEDATE="20180510"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="pcre2 python ruby static-libs ruby_targets_ruby23"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}:=[${MULTILIB_USEDEP}]
+ !pcre2? ( >=dev-libs/libpcre-8.33-r1:=[static-libs?,${MULTILIB_USEDEP}] )
+ pcre2? ( dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ ruby_targets_ruby23? ( dev-lang/ruby:2.3 )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ python? ( >=dev-lang/swig-2.0.9 )"
+
+src_prepare() {
+ eapply_user
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export AR CC PKG_CONFIG RANLIB
+
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ LDFLAGS="-fPIC ${LDFLAGS} -pthread" \
+ USE_PCRE2="$(usex pcre2 y n)" \
+ all
+
+ if multilib_is_native_abi && use python; then
+ building() {
+ emake \
+ LDFLAGS="-fPIC ${LDFLAGS} -lpthread" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ USE_PCRE2="$(usex pcre2 y n)" \
+ pywrap
+ }
+ python_foreach_impl building
+ fi
+
+ if multilib_is_native_abi && use ruby; then
+ building() {
+ einfo "Calling rubywrap for ${1}"
+ # Clean up .lo file to force rebuild
+ rm -f src/selinuxswig_ruby_wrap.lo || die
+ emake \
+ RUBY=${1} \
+ LDFLAGS="-fPIC ${LDFLAGS} -lpthread" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ USE_PCRE2="$(usex pcre2 y n)" \
+ rubywrap
+ }
+ for RUBYTARGET in ${USE_RUBY}; do
+ use ruby_targets_${RUBYTARGET} || continue
+
+ building ${RUBYTARGET}
+ done
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ USE_PCRE2="$(usex pcre2 y n)" \
+ install
+
+ if multilib_is_native_abi && use python; then
+ installation() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ USE_PCRE2="$(usex pcre2 y n)" \
+ install-pywrap
+ python_optimize # bug 531638
+ }
+ python_foreach_impl installation
+ fi
+
+ if multilib_is_native_abi && use ruby; then
+ installation() {
+ einfo "Calling install-rubywrap for ${1}"
+ # Forcing (re)build here as otherwise the resulting SO file is used for all ruby versions
+ rm src/selinuxswig_ruby_wrap.lo
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ RUBY=${1} \
+ USE_PCRE2="$(usex pcre2 y n)" \
+ install-rubywrap
+ }
+ for RUBYTARGET in ${USE_RUBY}; do
+ use ruby_targets_${RUBYTARGET} || continue
+
+ installation ${RUBYTARGET}
+ done
+ fi
+
+ use static-libs || rm "${D}"/usr/lib*/*.a || die
+}
+
+pkg_postinst() {
+ # Fix bug 473502
+ for POLTYPE in ${POLICY_TYPES};
+ do
+ mkdir -p /etc/selinux/${POLTYPE}/contexts/files || die
+ touch /etc/selinux/${POLTYPE}/contexts/files/file_contexts.local || die
+ # Fix bug 516608
+ for EXPRFILE in file_contexts file_contexts.homedirs file_contexts.local ; do
+ if [[ -f "/etc/selinux/${POLTYPE}/contexts/files/${EXPRFILE}" ]]; then
+ sefcontext_compile /etc/selinux/${POLTYPE}/contexts/files/${EXPRFILE} \
+ || die "Failed to recompile contexts"
+ fi
+ done
+ done
+}