summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-01-02 14:20:04 +0100
committerFabian Groffen <grobian@gentoo.org>2018-01-02 14:53:55 +0100
commit4ee391c4a0409d1c03eb47e0ce86050d6572fbea (patch)
tree2319aa6fc4347ab50ff3c60442b2f67591c1a3d2 /sys-libs
parentapp-admin/sudo: Bump to version 1.8.22_beta3. Removed old. (diff)
downloadgentoo-4ee391c4a0409d1c03eb47e0ce86050d6572fbea.tar.gz
gentoo-4ee391c4a0409d1c03eb47e0ce86050d6572fbea.tar.bz2
gentoo-4ee391c4a0409d1c03eb47e0ce86050d6572fbea.zip
sys-libs/compiler-rt: prefer compiler from prefix on Darwin
Patch by Michael Weiser Bug: https://bugs.gentoo.org/642644 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild9
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
index 9b135a41b328..d60c84ee2d67 100644
--- a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -77,6 +77,13 @@ src_configure() {
-DCOMPILER_RT_BUILD_XRAY=OFF
)
+ if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
+ mycmakeargs+=(
+ # disable use of SDK for the system itself
+ -DDARWIN_macosx_CACHED_SYSROOT=/
+ )
+ fi
+
if use test; then
mycmakeargs+=(
-DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
diff --git a/sys-libs/compiler-rt/compiler-rt-9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
index 4dd44182ae9b..7c6eb6db761e 100644
--- a/sys-libs/compiler-rt/compiler-rt-9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -81,6 +81,13 @@ src_configure() {
-DCOMPILER_RT_BUILD_XRAY=OFF
)
+ if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
+ mycmakeargs+=(
+ # disable use of SDK for the system itself
+ -DDARWIN_macosx_CACHED_SYSROOT=/
+ )
+ fi
+
if use test; then
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"