summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-04-29 15:46:13 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-04-29 15:47:12 -0400
commit4fdf45d8786ac98ac9f1240948453594f3460fba (patch)
tree7e1db81476235b8e32a0af107bc77d47f7fa8130 /sys-libs
parentsys-fs/encfs: keyworded 1.9.2 for sparc (diff)
downloadgentoo-4fdf45d8786ac98ac9f1240948453594f3460fba.tar.gz
gentoo-4fdf45d8786ac98ac9f1240948453594f3460fba.tar.bz2
gentoo-4fdf45d8786ac98ac9f1240948453594f3460fba.zip
sys-libs/uclibc-ng: fix ld.so.cache on amd64
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/uclibc-ng/files/uclibc-ng-1.0.30-fix-ld.so.cache.patch48
-rw-r--r--sys-libs/uclibc-ng/uclibc-ng-1.0.30-r1.ebuild (renamed from sys-libs/uclibc-ng/uclibc-ng-1.0.30.ebuild)3
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-libs/uclibc-ng/files/uclibc-ng-1.0.30-fix-ld.so.cache.patch b/sys-libs/uclibc-ng/files/uclibc-ng-1.0.30-fix-ld.so.cache.patch
new file mode 100644
index 000000000000..6b13e0890d25
--- /dev/null
+++ b/sys-libs/uclibc-ng/files/uclibc-ng-1.0.30-fix-ld.so.cache.patch
@@ -0,0 +1,48 @@
+commit 92d250d387e247029900c9074150f45866b29781
+Author: Waldemar Brodkorb <wbx@openadk.org>
+Date: Sun Apr 29 19:34:11 2018 +0200
+
+ Revert "ldconfig: add glibc compatibility fix"
+
+ This reverts commit 2a3bb4daf5778c5875674cd26a3c75b3d460a042.
+
+ This is breaking ld.so.cache usage. Seen on Gentoo/amd64.
+
+ Reported-by: "Anthony G. Basile" <basile@freeharbor.net>
+
+diff --git a/utils/ldconfig.c b/utils/ldconfig.c
+index 58939d689..e6b788118 100644
+--- a/utils/ldconfig.c
++++ b/utils/ldconfig.c
+@@ -184,9 +184,10 @@ static char *readsoname(char *name, FILE *infile, int expected_type,
+ res = readsoname32(name, infile, expected_type, type);
+ else {
+ res = readsoname64(name, infile, expected_type, type);
+-
+- // For 64-bit glibc compatibility
+- *type |= FLAG_X8664_LIB64;
++#if 0
++ /* relies on multilib support which we dont have ... */
++ *type |= LIB_ELF64;
++#endif
+ }
+
+ return res;
+@@ -757,7 +758,7 @@ void cache_print(void)
+
+ for (fd = 0; fd < header->nlibs; fd++) {
+ printf("\t%s ", strs + libent[fd].sooffset);
+- switch (libent[fd].flags & ~LIB_ELF64 & FLAG_TYPE_MASK) {
++ switch (libent[fd].flags & ~LIB_ELF64) {
+ case LIB_DLL:
+ printf("(libc4)");
+ break;
+@@ -770,7 +771,7 @@ void cache_print(void)
+ case LIB_ELF_LIBC5:
+ case LIB_ELF_LIBC6:
+ printf("(libc%d%s)",
+- (libent[fd].flags & ~LIB_ELF64 & FLAG_TYPE_MASK) + 3,
++ (libent[fd].flags & ~LIB_ELF64) + 3,
+ libent[fd].flags & LIB_ELF64 ? "/64" : "");
+ break;
+ default:
diff --git a/sys-libs/uclibc-ng/uclibc-ng-1.0.30.ebuild b/sys-libs/uclibc-ng/uclibc-ng-1.0.30-r1.ebuild
index 3b31357d8044..ca35a2cc5bc4 100644
--- a/sys-libs/uclibc-ng/uclibc-ng-1.0.30.ebuild
+++ b/sys-libs/uclibc-ng/uclibc-ng-1.0.30-r1.ebuild
@@ -252,6 +252,9 @@ src_prepare() {
# We want to get rid of this and just have ABI = 0.
eapply "${FILESDIR}"/uclibc-compat-r1.patch
+ # Critical fix for ld.so.cache
+ eapply "${FILESDIR}"/${P}-fix-ld.so.cache.patch
+
# We need to change the major.minor.sublevel of uclibc-ng.
# Upstream sets MAJOR_VERSION = 1 which breaks runtime linking.
# If we really want the ABI bump, we'll have to hack the gcc