summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-11-28 21:13:26 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-11-28 21:13:26 -0500
commit6d844bdd8b581c94b98e55a1178664a8551a6cdb (patch)
tree67b8fc4d9caacf3680e6eb0672c83c0fc586465a /sys-libs
parentsys-libs/musl: use short option for mktemp in ldconfig (diff)
downloadgentoo-6d844bdd8b581c94b98e55a1178664a8551a6cdb.tar.gz
gentoo-6d844bdd8b581c94b98e55a1178664a8551a6cdb.tar.bz2
gentoo-6d844bdd8b581c94b98e55a1178664a8551a6cdb.zip
sys-libs/musl: remove older stable version.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/musl/Manifest1
-rw-r--r--sys-libs/musl/musl-1.1.11-r1.ebuild129
2 files changed, 0 insertions, 130 deletions
diff --git a/sys-libs/musl/Manifest b/sys-libs/musl/Manifest
index d8961135065a..a4d38038c3f9 100644
--- a/sys-libs/musl/Manifest
+++ b/sys-libs/musl/Manifest
@@ -1,2 +1 @@
-DIST musl-1.1.11.tar.gz 915244 SHA256 bb9e6da51b7b12641f5d1abb39705c6c6c1b2fbd20002362948aa736a0aa353f SHA512 573131fe7a2c5a9c9bf796a5fc02e6ec093148648b9b43dc13d9c85e5777b1691499af6f673075a0d2b4b36c788b4dd7d72eb450c6ec3a586901bd410ee1ea6d WHIRLPOOL 17d5299b7554124ec49c2309f9385313cffe0f2126812bbcce87a142b2138153b5634579a33554edba6b76aab87f96ef2bb5dc0773cc9b930356b7da6e0b61fb
DIST musl-1.1.12.tar.gz 918757 SHA256 720b83c7e276b4b679c0bffe9509340d5f81fd601508e607e708177df0d31c0e SHA512 7cabbe2665e32bd3408c8865f89f474106e982b4e5de81d0cdeea19e19e20b4d2496faf1adc6b2811d996f30f39258184ba347e8eb5f3811eab89179e8f52d70 WHIRLPOOL cd500c3457be42d8dd927420d2352bda87e7b424fabf19fbd387858b913636793a7ff8d0e249bcc292e58c6d0d3889738c8790f3a6409d6df2da81408a77238c
diff --git a/sys-libs/musl/musl-1.1.11-r1.ebuild b/sys-libs/musl/musl-1.1.11-r1.ebuild
deleted file mode 100644
index 018860e49203..000000000000
--- a/sys-libs/musl/musl-1.1.11-r1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils flag-o-matic multilib toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.musl-libc.org/musl"
- inherit git-2
-fi
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY} == cross-* ]] ; then
- export CTARGET=${CATEGORY#cross-}
- fi
-fi
-
-DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
-HOMEPAGE="http://www.musl-libc.org/"
-if [[ ${PV} != "9999" ]] ; then
- PATCH_VER=""
- SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
- KEYWORDS="-* amd64 arm ~mips ppc x86"
-fi
-
-LICENSE="MIT LGPL-2 GPL-2"
-SLOT="0"
-IUSE="crosscompile_opts_headers-only"
-
-RDEPEND="!sys-apps/getent"
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-
-just_headers() {
- use crosscompile_opts_headers-only && is_crosscompile
-}
-
-musl_endian() {
- # XXX: this wont work for bi-endian, but we dont have any
- touch "${T}"/endian.s
- $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
- case $(file "${T}"/endian.o) in
- *" MSB "*) echo "";;
- *" LSB "*) echo "el";;
- *) echo "nfc";; # We shouldn't be here
- esac
-}
-
-pkg_setup() {
- if [ ${CTARGET} == ${CHOST} ] ; then
- case ${CHOST} in
- *-musl*) ;;
- *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
- esac
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fix-codeset.patch
- epatch_user
-}
-
-src_configure() {
- tc-getCC ${CTARGET}
- just_headers && export CC=true
-
- local sysroot
- is_crosscompile && sysroot=/usr/${CTARGET}
- ./configure \
- --target=${CTARGET} \
- --prefix=${sysroot}/usr \
- --syslibdir=${sysroot}/lib \
- --disable-gcc-wrapper
-}
-
-src_compile() {
- emake include/bits/alltypes.h || die
- just_headers && return 0
-
- emake || die
-}
-
-src_install() {
- local target="install"
- just_headers && target="install-headers"
- emake DESTDIR="${D}" ${target} || die
- just_headers && return 0
-
- # musl provides ldd via a sym link to its ld.so
- local sysroot
- is_crosscompile && sysroot=/usr/${CTARGET}
- local ldso=$(basename "${D}"${sysroot}/lib/ld-musl-*)
- dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
-
- if [[ ${CATEGORY} != cross-* ]] ; then
- local target=$(tc-arch) arch
- local endian=$(musl_endian)
- case ${target} in
- amd64) arch="x86_64";;
- arm) arch="armhf";; # We only have hardfloat right now
- mips) arch="mips${endian}";;
- ppc) arch="powerpc";;
- x86) arch="i386";;
- esac
- cp "${FILESDIR}"/ldconfig.in "${T}"
- sed -e "s|@@ARCH@@|${arch}|" "${T}"/ldconfig.in > "${T}"/ldconfig
- into /
- dosbin "${T}"/ldconfig
- into /usr
- dobin "${FILESDIR}"/getent
- echo 'LDPATH="include ld.so.conf.d/*.conf"' > "${T}"/00musl
- doenvd "${T}"/00musl || die
- fi
-}
-
-pkg_postinst() {
- is_crosscompile && return 0
-
- [ "${ROOT}" != "/" ] && return 0
-
- ldconfig
- # reload init ...
- /sbin/telinit U 2>/dev/null
-}