summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-09 22:48:53 +0000
committerSam James <sam@gentoo.org>2021-06-09 23:55:49 +0000
commit7589439e29ef225b4fd936af8203f8ae8969021b (patch)
tree9e0d8dc62904189b4a1cff2293d45ba19dd659d5 /sys-libs
parentnet-misc/nyx: require python[ncurses] (diff)
downloadgentoo-7589439e29ef225b4fd936af8203f8ae8969021b.tar.gz
gentoo-7589439e29ef225b4fd936af8203f8ae8969021b.tar.bz2
gentoo-7589439e29ef225b4fd936af8203f8ae8969021b.zip
sys-libs/fortify-headers: add 1.1
Closes: https://bugs.gentoo.org/716234 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/fortify-headers/Manifest1
-rw-r--r--sys-libs/fortify-headers/fortify-headers-0.6.ebuild5
-rw-r--r--sys-libs/fortify-headers/fortify-headers-0.7.ebuild5
-rw-r--r--sys-libs/fortify-headers/fortify-headers-1.1.ebuild36
-rw-r--r--sys-libs/fortify-headers/fortify-headers-9999.ebuild30
5 files changed, 62 insertions, 15 deletions
diff --git a/sys-libs/fortify-headers/Manifest b/sys-libs/fortify-headers/Manifest
index f31dc4adc86b..3884323f6351 100644
--- a/sys-libs/fortify-headers/Manifest
+++ b/sys-libs/fortify-headers/Manifest
@@ -1,2 +1,3 @@
DIST fortify-headers-0.6.tar.gz 5339 BLAKE2B 404a20de075551e11750f989e05d78f450b09fc879a7ff4b649773ebc012a93c42432cc7b60c70843a375d64f6aea3ec356cdfafc0133f8cc58dadfea9b982d3 SHA512 6106219332515e7c23354d916383cdac6efccba7eefa13b0c2c221d0fd03be7afb29b3a8622bd29b62ee0b602f9d1f273e1a08c07583bdcd12db9938ef4d7acc
DIST fortify-headers-0.7.tar.gz 5524 BLAKE2B 76ec4ee5b50bc77db05bf45a4a5550f3a369e5a49e333cd095613acbc04794d074103f3110c353a3283757f12cec866c45ed7d71ef4509667cae49926ee6953a SHA512 9335d5042f973904cf131d4894c71d3d25c84e82427500064a4ed3f798abd8051c3b52375a17c807ca89227115fa5ba9922939f0e86059a9f04fee61f0b69e53
+DIST fortify-headers-1.1.tar.gz 5510 BLAKE2B d0454ad3ba432c051aeabfffad82799fae4ef37c07a8d2b8efcc26cd867dea8b31586f312d2947cb7e6ef7eedcacc3bb68591be4409376cc702ffbbafe144ea0 SHA512 a39d6e7c002bf91085f712aa46bc3f53ff934cc963694a229fa82d84ff4a7556105212a84a231ab5367c01c6a1e385172173f1f4a34d5eb4d2d9c58472c23dd0
diff --git a/sys-libs/fortify-headers/fortify-headers-0.6.ebuild b/sys-libs/fortify-headers/fortify-headers-0.6.ebuild
index 9f9374176ea0..e717acf59e4c 100644
--- a/sys-libs/fortify-headers/fortify-headers-0.6.ebuild
+++ b/sys-libs/fortify-headers/fortify-headers-0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,7 +7,8 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="git://git.2f30.org/fortify-headers"
inherit git-r3
else
- SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ #SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ SRC_URI="https://dl.2f30.org/releases/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
fi
diff --git a/sys-libs/fortify-headers/fortify-headers-0.7.ebuild b/sys-libs/fortify-headers/fortify-headers-0.7.ebuild
index 9f9374176ea0..e717acf59e4c 100644
--- a/sys-libs/fortify-headers/fortify-headers-0.7.ebuild
+++ b/sys-libs/fortify-headers/fortify-headers-0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,7 +7,8 @@ if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="git://git.2f30.org/fortify-headers"
inherit git-r3
else
- SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ #SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ SRC_URI="https://dl.2f30.org/releases/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
fi
diff --git a/sys-libs/fortify-headers/fortify-headers-1.1.ebuild b/sys-libs/fortify-headers/fortify-headers-1.1.ebuild
new file mode 100644
index 000000000000..5347e1e57683
--- /dev/null
+++ b/sys-libs/fortify-headers/fortify-headers-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="git://git.2f30.org/fortify-headers"
+ inherit git-r3
+else
+ #SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ SRC_URI="https://dl.2f30.org/releases/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+fi
+
+DESCRIPTION="A standalone implementation of fortify source"
+HOMEPAGE="http://git.2f30.org/fortify-headers/"
+
+LICENSE="ISC"
+SLOT="0"
+
+src_prepare() {
+ sed -i -e 's|^PREFIX = /usr/local|PREFIX = /usr|g' Makefile || die
+ default
+}
+
+src_compile() {
+ # Nothing to do here but defining a dummy phase allows us to not trigger
+ # the catch-all rule and try to install here where we don't have access
+ # to ${ED}
+ :;
+}
+
+src_install() {
+ export DESTDIR="${ED}"
+ default
+}
diff --git a/sys-libs/fortify-headers/fortify-headers-9999.ebuild b/sys-libs/fortify-headers/fortify-headers-9999.ebuild
index 9f9374176ea0..5347e1e57683 100644
--- a/sys-libs/fortify-headers/fortify-headers-9999.ebuild
+++ b/sys-libs/fortify-headers/fortify-headers-9999.ebuild
@@ -1,28 +1,36 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="git://git.2f30.org/fortify-headers"
inherit git-r3
else
- SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ #SRC_URI="http://git.2f30.org/fortify-headers/snapshot/fortify-headers-${PV}.tar.gz"
+ SRC_URI="https://dl.2f30.org/releases/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
fi
-DESCRIPTION="A standalone implementation of fortify source."
+DESCRIPTION="A standalone implementation of fortify source"
HOMEPAGE="http://git.2f30.org/fortify-headers/"
LICENSE="ISC"
SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
src_prepare() {
- sed -i -e 's|^PREFIX = /usr/local|PREFIX = /usr|g' Makefile
- export DESTDIR="${D}"
- eapply_user
+ sed -i -e 's|^PREFIX = /usr/local|PREFIX = /usr|g' Makefile || die
+ default
+}
+
+src_compile() {
+ # Nothing to do here but defining a dummy phase allows us to not trigger
+ # the catch-all rule and try to install here where we don't have access
+ # to ${ED}
+ :;
+}
+
+src_install() {
+ export DESTDIR="${ED}"
+ default
}