summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-13 10:03:32 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-13 10:05:16 +0200
commit778a215f6677b69f7a1d76e1bc664c30d108fd00 (patch)
tree9fec3b18ce31e6fd1ce46b5bbd19059b743d75aa /sys-libs
parentdev-util/scons: Add new revision with Python 3 support (diff)
downloadgentoo-778a215f6677b69f7a1d76e1bc664c30d108fd00.tar.gz
gentoo-778a215f6677b69f7a1d76e1bc664c30d108fd00.tar.bz2
gentoo-778a215f6677b69f7a1d76e1bc664c30d108fd00.zip
sys-libs/uclibc: Revert "git-2->git-r3, explicit EAPI=0"
This change blocks prior patch removing EAPI=0 support from git-r3. If you really want to keep this live ebuild, please update it to use newer EAPI. Otherwise, removing it would be a better solution.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild27
-rw-r--r--sys-libs/uclibc/uclibc-0.9.33.9999.ebuild26
-rw-r--r--sys-libs/uclibc/uclibc-9999.ebuild26
3 files changed, 36 insertions, 43 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild b/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
index 4c712c8a69a8..32bb54180854 100644
--- a/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
@@ -1,20 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
-
inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
-
-MY_P=uClibc-${PV}
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://git.busybox.net/uClibc"
- EGIT_BRANCH="0.9.33"
- inherit git-r3
-else
- PATCH_VER="17"
- SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
- ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
- KEYWORDS="-* amd64 arm m68k ~mips ppc sh sparc x86"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.busybox.net/uClibc"
+ inherit git-2
fi
export CBUILD=${CBUILD:-${CHOST}}
@@ -25,8 +15,15 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
+MY_P=uClibc-${PV}
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="https://www.uclibc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER="17"
+ SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
+ ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
+ KEYWORDS="-* amd64 arm m68k ~mips ppc sh sparc x86"
+fi
LICENSE="LGPL-2"
SLOT="0"
@@ -235,8 +232,8 @@ src_config() {
}
src_unpack() {
- if [[ ${PV} == *9999* ]] ; then
- git-r3_src_unpack
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
else
unpack ${A}
fi
diff --git a/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild b/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
index d55f0afff6da..fbc8a60a1fc9 100644
--- a/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
@@ -1,20 +1,11 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
-
inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
-
-MY_P=uClibc-${PV}
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://git.busybox.net/uClibc"
+if [[ ${PV} == *9999 ]] ; then
EGIT_BRANCH="0.9.33"
- inherit git-r3
-else
- PATCH_VER=""
- SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
- ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
- KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+ EGIT_REPO_URI="git://git.busybox.net/uClibc"
+ inherit git-2
fi
export CBUILD=${CBUILD:-${CHOST}}
@@ -25,8 +16,15 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
+MY_P=uClibc-${PV}
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="https://www.uclibc.org/"
+if [[ ${PV} != *9999 ]] ; then
+ PATCH_VER=""
+ SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
+ ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
+ KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+fi
LICENSE="LGPL-2"
SLOT="0"
@@ -233,8 +231,8 @@ src_config() {
}
src_unpack() {
- if [[ ${PV} == *9999* ]] ; then
- git-r3_src_unpack
+ if [[ ${PV} == *9999 ]] ; then
+ git-2_src_unpack
else
unpack ${A}
fi
diff --git a/sys-libs/uclibc/uclibc-9999.ebuild b/sys-libs/uclibc/uclibc-9999.ebuild
index 3e096317babc..f5cec3749e75 100644
--- a/sys-libs/uclibc/uclibc-9999.ebuild
+++ b/sys-libs/uclibc/uclibc-9999.ebuild
@@ -1,19 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
-
inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
-
-MY_P=uClibc-${PV}
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://git.busybox.net/uClibc"
- inherit git-r3
-else
- PATCH_VER=""
- SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
- ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
- KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.busybox.net/uClibc"
+ inherit git-2
fi
export CBUILD=${CBUILD:-${CHOST}}
@@ -24,8 +15,15 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
+MY_P=uClibc-${PV}
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="https://www.uclibc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER=""
+ SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
+ ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
+ KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+fi
LICENSE="LGPL-2"
SLOT="0"
@@ -232,8 +230,8 @@ src_config() {
}
src_unpack() {
- if [[ ${PV} == *9999* ]] ; then
- git-r3_src_unpack
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
else
unpack ${A}
fi