summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-01 20:03:00 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-01 21:05:57 +0200
commit965d9a2387a3a2fd5f525e3390067de41fee343f (patch)
tree14ee07c253cedef66c462e60424aeac36e27cb23 /sys-libs
parentapp-portage/unsandbox: Introduce the sandbox escape tool (diff)
downloadgentoo-965d9a2387a3a2fd5f525e3390067de41fee343f.tar.gz
gentoo-965d9a2387a3a2fd5f525e3390067de41fee343f.tar.bz2
gentoo-965d9a2387a3a2fd5f525e3390067de41fee343f.zip
sys-libs/compiler-rt-sanitizers: Use app-portage/unsandbox for tests
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
index 9b280fd0ba34..c83df17c1d71 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-9999.ebuild
@@ -25,7 +25,9 @@ RDEPEND="${PYTHON_DEPS}
!<sys-devel/llvm-${PV}"
DEPEND="${RDEPEND}
~sys-devel/llvm-${PV}
- test? ( dev-python/lit[${PYTHON_USEDEP}]
+ test? (
+ app-portage/unsandbox
+ dev-python/lit[${PYTHON_USEDEP}]
~sys-devel/clang-${PV}
~sys-libs/compiler-rt-${PV} )
${PYTHON_DEPS}"
@@ -70,7 +72,7 @@ src_configure() {
if use test; then
mycmakeargs+=(
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
+ -DLIT_COMMAND="${EPREFIX}/usr/bin/unsandbox;${EPREFIX}/usr/bin/lit"
# they are created during src_test()
-DCOMPILER_RT_TEST_COMPILER="${BUILD_DIR}/bin/clang"
@@ -102,9 +104,6 @@ src_configure() {
}
src_test() {
- # sandbox breaks libasan tests... and is hard to kill
- # so abuse the fail in its algorithms
- local -x LD_PRELOAD=${LD_PRELOAD/libsandbox/nolibsandbox}
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1