summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-14 23:03:52 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-14 23:22:25 +0100
commitaea339cafa2867e9aaaf06c3d89ead6d97939f24 (patch)
tree30795909810e84bd558c89e76b670f4ac3feb61a /sys-libs
parentsys-libs/libcxxabi: Use llvm.eclass for reliable upgrade from :0 (diff)
downloadgentoo-aea339cafa2867e9aaaf06c3d89ead6d97939f24.tar.gz
gentoo-aea339cafa2867e9aaaf06c3d89ead6d97939f24.tar.bz2
gentoo-aea339cafa2867e9aaaf06c3d89ead6d97939f24.zip
sys-libs/libcxx: Use llvm.eclass for reliable upgrade from :0
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/libcxx-4.0.0.ebuild3
-rw-r--r--sys-libs/libcxx/libcxx-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/sys-libs/libcxx/libcxx-4.0.0.ebuild b/sys-libs/libcxx/libcxx-4.0.0.ebuild
index 691e252ab026..ce256df08e8f 100644
--- a/sys-libs/libcxx/libcxx-4.0.0.ebuild
+++ b/sys-libs/libcxx/libcxx-4.0.0.ebuild
@@ -10,7 +10,7 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-multilib python-any-r1 toolchain-funcs
+inherit cmake-multilib llvm python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="http://libcxx.llvm.org/"
@@ -54,6 +54,7 @@ python_check_deps() {
}
pkg_setup() {
+ llvm_pkg_setup
use test && python-any-r1_pkg_setup
if ! use libcxxabi && ! use libcxxrt && ! tc-is-gcc ; then
diff --git a/sys-libs/libcxx/libcxx-9999.ebuild b/sys-libs/libcxx/libcxx-9999.ebuild
index 0f39966844bb..c063388b1adc 100644
--- a/sys-libs/libcxx/libcxx-9999.ebuild
+++ b/sys-libs/libcxx/libcxx-9999.ebuild
@@ -14,7 +14,7 @@ PYTHON_COMPAT=( python2_7 )
[[ ${PV} == 9999 ]] && SCM="git-r3" || SCM=""
-inherit ${SCM} cmake-multilib python-any-r1 toolchain-funcs
+inherit ${SCM} cmake-multilib llvm python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="http://libcxx.llvm.org/"
@@ -65,6 +65,7 @@ python_check_deps() {
}
pkg_setup() {
+ llvm_pkg_setup
use test && python-any-r1_pkg_setup
if ! use libcxxabi && ! use libcxxrt && ! tc-is-gcc ; then