summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-02-22 16:28:41 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-02-22 16:33:07 +0100
commitaee2389acc66f1555ff924525c7b56bba2575b0d (patch)
tree189e38542ce5e13b34280bbcb304846fd7876f71 /sys-libs
parentdev-util/github-cli: remove old (diff)
downloadgentoo-aee2389acc66f1555ff924525c7b56bba2575b0d.tar.gz
gentoo-aee2389acc66f1555ff924525c7b56bba2575b0d.tar.bz2
gentoo-aee2389acc66f1555ff924525c7b56bba2575b0d.zip
sys-libs/liburing: Revbump to fix version in pkgconfig files
Closes: https://bugs.gentoo.org/833895 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/liburing/liburing-2.1-r1.ebuild (renamed from sys-libs/liburing/liburing-2.1.ebuild)11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-libs/liburing/liburing-2.1.ebuild b/sys-libs/liburing/liburing-2.1-r1.ebuild
index 268300b356e1..ae14b067cbb3 100644
--- a/sys-libs/liburing/liburing-2.1.ebuild
+++ b/sys-libs/liburing/liburing-2.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib-minimal toolchain-funcs
@@ -28,6 +28,13 @@ PATCHES=(
src_prepare() {
default
+
+ if [[ "${PV}" != *9999 ]] ; then
+ # Make sure pkgconfig files contain the correct version
+ # bug #809095 and #833895
+ sed -i "/^Version:/s@[[:digit:]\.]\+@${PV}@" ${PN}.spec || die
+ fi
+
multilib_copy_sources
}