summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-12 21:27:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-12 22:09:42 +0200
commitb08684865e4a7fdd49cabee0d1b0c333b8199b89 (patch)
tree85eefb0b86476aa06f182ef90d453cfc9cbe668f /sys-libs
parentapp-text/tidy-html5: Version bump. (diff)
downloadgentoo-b08684865e4a7fdd49cabee0d1b0c333b8199b89.tar.gz
gentoo-b08684865e4a7fdd49cabee0d1b0c333b8199b89.tar.bz2
gentoo-b08684865e4a7fdd49cabee0d1b0c333b8199b89.zip
sys-libs/tdb: Bump to version 1.3.9
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tdb/Manifest1
-rw-r--r--sys-libs/tdb/tdb-1.3.9.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index 99eb77850b7f..cc781f3a68ca 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -1 +1,2 @@
DIST tdb-1.3.8.tar.gz 494106 SHA256 0605ac0427eac9c23bf61ebfd8206a07d5ece198498eab1769cd0cfb6e7de6b1 SHA512 9a7040206bbaae419a296714fe14fcbd3b67c0cef2b0f33563d52336aac2fe814049f5136a148fb049a273bb36fe81e3d777df58869c93f45d6e42b4adf9970b WHIRLPOOL 61070a71aba9b44d5141844ffac6b4657ddc938850934fe00ff7312d9f76e1c318e37764b60fbac255ff5b8dc8d8226f668f80315fccdc67550eeb9bd1c4bc25
+DIST tdb-1.3.9.tar.gz 493585 SHA256 7101f726e6d5c70f14e577b01c133e2e6059c4455239115e56a12ba64fc084d2 SHA512 ee724e54d6eef51cb368bccbf41a1ab326f3b618e8366d8b43b91953a30e4c486842cd7f41b83f613becb1e4117ce4831b1065d6efdcf14bb96b545ef1dd8175 WHIRLPOOL eb27d028b0f09c66e6e64783cd9bbf44d238bf70816879455ae59d268df7dd07ae0f9f4b634ac78224ca9b6b867e711b13cdb9aa75cfb6a2154d447def761d17
diff --git a/sys-libs/tdb/tdb-1.3.9.ebuild b/sys-libs/tdb/tdb-1.3.9.ebuild
new file mode 100644
index 000000000000..6f54a5a44321
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.3.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}