summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-01-11 17:37:25 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-11 17:37:41 -0500
commitb3770d1862020d5cc1e0a689b97816b5303d1ec9 (patch)
treed9df7ee54d5c73e0f05b29680fbfa9308867bc56 /sys-libs
parentsys-kernel/linux-firmware: stable 20180103-r1 for ia64, bug #643476 (diff)
downloadgentoo-b3770d1862020d5cc1e0a689b97816b5303d1ec9.tar.gz
gentoo-b3770d1862020d5cc1e0a689b97816b5303d1ec9.tar.bz2
gentoo-b3770d1862020d5cc1e0a689b97816b5303d1ec9.zip
sys-libs/libseccomp: version bump to 2.3.3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libseccomp/Manifest1
-rw-r--r--sys-libs/libseccomp/libseccomp-2.3.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/Manifest b/sys-libs/libseccomp/Manifest
index 4613f66001dd..3949345d1019 100644
--- a/sys-libs/libseccomp/Manifest
+++ b/sys-libs/libseccomp/Manifest
@@ -1,3 +1,4 @@
DIST libseccomp-2.3.0.tar.gz 546948 BLAKE2B 084ad3b0dd9833a5439ab4cfcf3ecf3bfa4f4943a20c249f02229fcfbc60024de18b1593235dd14fa5701d5ab53f29518b5d2fcb39b2b0054b1172238e8a2536 SHA512 398643af0920ff446b37a74e48f7a96ad2bec4f514e92fc6f8242b7515dcb8f5d06c2894790b22f62387c2d9b75efd54a4d5944f973239a05f06ec840f2a5a0b
DIST libseccomp-2.3.1.tar.gz 552299 BLAKE2B 24460f29dff3bbbef809fb82c2ee58deb1b659ae236d369c554212dbfb8a27497bc44dc27fc76ad0eed6d1f9c50c52f05e52ce7f4996aa6dbbe3c0d960edae17 SHA512 246b30e1c513d5e1fa35a47905d99036e276c1e6483a96f3e79ddca536a8c6f641c11bf324ed10c9c8d18fa27d73667c9c72fc7459f827d2883926769ac1cb45
DIST libseccomp-2.3.2.tar.gz 559238 BLAKE2B 0040ad977431ae9731dadcae11b0099d3ec788462f89cdf80c77b71405ce02c122c3859836aaa9469ec7112b0bf32cc87c9b102bb3e8b2e669ded54677db64d1 SHA512 0864a53ba2be61d0207f7361af94bcda4acff84a1814f915e6ccb19ab24f6ccc978da0eedc5cee047fa655dc1a583e2eeb7ab985ebfc77491c6a2606727b79ec
+DIST libseccomp-2.3.3.tar.gz 564546 BLAKE2B b5249379baf07ab2fef8a8659a30c9e87cbf05f99c38a07c1516948d2ede27d505f6670426f46422d2a927d7bfe97a33d8f871899ae9c30a26fbd10fba609df8 SHA512 845c7e0e916b5f5ad74da446ceff3250148b745c909185f6d5059e807d1b42fa6b74f356cce2a396bff0d4c7a3120e7cdad98d490a97d549327c7693fe1918be
diff --git a/sys-libs/libseccomp/libseccomp-2.3.3.ebuild b/sys-libs/libseccomp/libseccomp-2.3.3.ebuild
new file mode 100644
index 000000000000..e70326756c71
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-2.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~x86"
+IUSE="static-libs"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND=">=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+ sed -i \
+ -e '/_LDFLAGS/s:-static::' \
+ tools/Makefile.in || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-python
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name libseccomp.la -delete
+ einstalldocs
+}