summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-01 11:54:28 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-02 00:40:41 +0100
commitb983b35c7ecd103f79423050fb15fb0f6284d0d3 (patch)
tree3c723a9b7af9c89da5637510bd31a0d154b6bd43 /sys-libs
parentsys-libs/libcxx: Bump to 5.0.1_rc2 (diff)
downloadgentoo-b983b35c7ecd103f79423050fb15fb0f6284d0d3.tar.gz
gentoo-b983b35c7ecd103f79423050fb15fb0f6284d0d3.tar.bz2
gentoo-b983b35c7ecd103f79423050fb15fb0f6284d0d3.zip
sys-libs/libomp: Bump to 5.0.1_rc2
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libomp/Manifest1
-rw-r--r--sys-libs/libomp/libomp-5.0.1_rc2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/sys-libs/libomp/Manifest b/sys-libs/libomp/Manifest
index 78f1468c3605..c7906cb851d3 100644
--- a/sys-libs/libomp/Manifest
+++ b/sys-libs/libomp/Manifest
@@ -4,3 +4,4 @@ DIST openmp-3.9.0.src.tar.xz 2257596 SHA256 df88f90d7e5b5e9525a35fa2e2b93cbbb83c
DIST openmp-3.9.1.src.tar.xz 2031588 SHA256 d23b324e422c0d5f3d64bae5f550ff1132c37a070e43c7ca93991676c86c7766 SHA512 80924a6f9765f634d24d7b0aa036d92c912dbd8e067487a14bdd03b4c587fdfc92e83eb29926bfa637ef45be3f133a924f77ab12099ea3706c18e9c42774708b WHIRLPOOL b6ec75d4f9d2b86bb8e2927791cb46e61ff8657fc21f9e0ba9893d81d3382522aca330564f3156c1fbbf765de0499e875e41e11199abe2da8ed1bef057d5e8d8
DIST openmp-4.0.1.src.tar.xz 2275240 SHA256 ec693b170e0600daa7b372240a06e66341ace790d89eaf4a843e8d56d5f4ada4 SHA512 0b737dde832c5907a0cac41fe1d594b61e85dd405eee42b39f09233db62b44543204ccc775e52e2981f9c9f0683b234526e288a3a7a04f712280fb3a575abcaf WHIRLPOOL 102f4b6984e6bc4dc08349e7f1f0ff31646bad923018cfd342e0bee760d8b1036f0c54c565af3b0730c470d584e37ed905bcbfa1ffc2325dafa0a02d91088b05
DIST openmp-5.0.0.src.tar.xz 2074004 SHA256 c0ef081b05e0725a04e8711d9ecea2e90d6c3fbb1622845336d3d095d0a3f7c5 SHA512 038cc1d262414fac9a05eabdce97b21eb04fc1b3609d07f8da2c9da6b1aaa143f8b26953cb799e7dde82f708103539fe03fe939ba7323a71bd3e9e3925bd5513 WHIRLPOOL e32436cc925173db2f58dc0b454ed046c733877edce3383da0a621ea90e9c30d9e45c0063451feb9b0dc95102893db02832d97bfb3a200e3440e4cad7fb9720a
+DIST openmp-5.0.1rc2.src.tar.xz 2076308 BLAKE2B 8728f9da3f8627ff10dadf36eeabeeb6b7228a2c36fec13f679c7f4cbed680fb7b177f7d188dd001292062577468b71b0d14643df86974c9849c0e9876726821 SHA512 9d4464f4f22164057bd8d0225d1c5d90df54331a6b63a905032c7b0e3e380b2d689dd08b3175c53e6aae95315060f107a2fb15bc23738a20cbd6e1751c5d789b
diff --git a/sys-libs/libomp/libomp-5.0.1_rc2.ebuild b/sys-libs/libomp/libomp-5.0.1_rc2.ebuild
new file mode 100644
index 000000000000..174b86c806f4
--- /dev/null
+++ b/sys-libs/libomp/libomp-5.0.1_rc2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-multilib python-any-r1
+
+DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
+HOMEPAGE="https://openmp.llvm.org"
+SRC_URI="http://prereleases.llvm.org/${PV/_//}/openmp-${PV/_/}.src.tar.xz"
+
+# Additional licenses:
+# - MIT-licensed Intel code,
+# - LLVM Software Grant from Intel.
+
+LICENSE="|| ( UoI-NCSA MIT ) MIT LLVM-Grant"
+SLOT="0"
+KEYWORDS=""
+IUSE="hwloc ompt test"
+
+RDEPEND="hwloc? ( sys-apps/hwloc:0=[${MULTILIB_USEDEP}] )"
+# tests:
+# - dev-python/lit provides the test runner
+# - sys-devel/llvm provide test utils (e.g. FileCheck)
+# - sys-devel/clang provides the compiler to run tests
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ test? (
+ $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
+ sys-devel/llvm
+ >=sys-devel/clang-3.9.0
+ )"
+
+S=${WORKDIR}/openmp-${PV/_/}.src
+
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+python_check_deps() {
+ has_version "dev-python/lit[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ local libdir="$(get_libdir)"
+ local mycmakeargs=(
+ -DLIBOMP_LIBDIR_SUFFIX="${libdir#lib}"
+ -DLIBOMP_USE_HWLOC=$(usex hwloc)
+ -DLIBOMP_OMPT_SUPPORT=$(usex ompt)
+ # do not install libgomp.so & libiomp5.so aliases
+ -DLIBOMP_INSTALL_ALIASES=OFF
+ # disable unnecessary hack copying stuff back to srcdir
+ -DLIBOMP_COPY_EXPORTS=OFF
+ -DLIBOMP_TEST_COMPILER="$(type -P "${CHOST}-clang")"
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_test() {
+ # respect TMPDIR!
+ local -x LIT_PRESERVES_TMP=1
+
+ cmake-utils_src_make check-libomp
+}