summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-07 08:12:49 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-07 10:39:54 +0100
commitc8d170da873918e7969852ffdd48ff2904f65432 (patch)
treea6bcbc28510f791bbba63453e652bdf54af5f131 /sys-libs
parentvirtual/dist-kernel: stabilize 5.4.129 for ppc64 (diff)
downloadgentoo-c8d170da873918e7969852ffdd48ff2904f65432.tar.gz
gentoo-c8d170da873918e7969852ffdd48ff2904f65432.tar.bz2
gentoo-c8d170da873918e7969852ffdd48ff2904f65432.zip
sys-libs/libunwind: fix ABI_X86=x32 build
Reported-by: Jan Ziak Closes: https://bugs.gentoo.org/614374 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libunwind/files/libunwind-1.5.0-x32.patch17
-rw-r--r--sys-libs/libunwind/libunwind-1.5.0-r1.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/sys-libs/libunwind/files/libunwind-1.5.0-x32.patch b/sys-libs/libunwind/files/libunwind-1.5.0-x32.patch
new file mode 100644
index 000000000000..a3bbc81f45b5
--- /dev/null
+++ b/sys-libs/libunwind/files/libunwind-1.5.0-x32.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/614374
+
+From: kasperk81 <83082615+kasperk81@users.noreply.github.com>
+Date: Wed, 30 Jun 2021 23:23:22 +0000
+Subject: [PATCH] Fix -mx32 compilation error
+
+--- a/src/x86_64/Gos-linux.c
++++ b/src/x86_64/Gos-linux.c
+@@ -149,7 +149,7 @@ x86_64_sigreturn (unw_cursor_t *cursor)
+ __asm__ __volatile__ ("mov %0, %%rsp;"
+ "mov %1, %%rax;"
+ "syscall"
+- :: "r"(sc), "i"(SYS_rt_sigreturn)
++ :: "r"((uint64_t)sc), "i"(SYS_rt_sigreturn)
+ : "memory");
+ abort();
+ }
diff --git a/sys-libs/libunwind/libunwind-1.5.0-r1.ebuild b/sys-libs/libunwind/libunwind-1.5.0-r1.ebuild
index ae510ed27fe0..082fdab6ed88 100644
--- a/sys-libs/libunwind/libunwind-1.5.0-r1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.5.0-r1.ebuild
@@ -49,6 +49,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.2-coredump-regs.patch #586092
"${FILESDIR}"/${PN}-1.2-ia64-ptrace-coredump.patch
"${FILESDIR}"/${PN}-1.2-ia64-missing.patch
+ "${FILESDIR}"/${PN}-1.5.0-x32.patch
# needs refresh:
#"${FILESDIR}"/${PN}-1.2.1-only-include-execinfo_h-if-avaliable.patch
)