summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-07-05 22:00:23 +0200
committerSam James <sam@gentoo.org>2021-10-20 03:26:07 +0000
commitcdd0363be9f629c0d0527e0e4d4994117eca9230 (patch)
treeab22ab28b7c8658a7c89dcc9da6850eb9aed01fe /sys-libs
parentsys-auth/libfprint: bump to 1.92.0 (diff)
downloadgentoo-cdd0363be9f629c0d0527e0e4d4994117eca9230.tar.gz
gentoo-cdd0363be9f629c0d0527e0e4d4994117eca9230.tar.bz2
gentoo-cdd0363be9f629c0d0527e0e4d4994117eca9230.zip
sys-libs/pam_wrapper: merge fprintd and pam_wrapper
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/pam_wrapper/pam_wrapper-1.1.3-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/sys-libs/pam_wrapper/pam_wrapper-1.1.3-r1.ebuild b/sys-libs/pam_wrapper/pam_wrapper-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..a95f837c4bb9
--- /dev/null
+++ b/sys-libs/pam_wrapper/pam_wrapper-1.1.3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+CMAKE_ECLASS=cmake
+
+inherit cmake-multilib python-r1
+
+DESCRIPTION="A tool to test PAM applications and PAM modules"
+HOMEPAGE="https://cwrap.org/pam_wrapper.html"
+SRC_URI="
+ https://www.samba.org/ftp/pub/cwrap/${P}.tar.gz
+ https://ftp.samba.org/pub/cwrap/${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sys-libs/pam:0=[${MULTILIB_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka[${MULTILIB_USEDEP}] )
+"
+
+multilib_src_configure() {
+ configure_for_python() {
+ local libpam="${EPREFIX}"
+ multilib_is_native_abi || libpam+="/usr"
+ libpam+="/$(get_libdir)/libpam.so.0"
+
+ local mycmakeargs=(
+ -DPAM_LIBRARY="${libpam}"
+ -DUNIT_TESTING=$(usex test)
+ -DPYTHON2_LIBRARY="/dev/null" # Disabled
+ -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON3_SITELIB="$(python_get_sitedir)"
+ )
+ cmake_src_configure
+ }
+ python_foreach_impl configure_for_python
+}
+
+multilib_src_compile() {
+ python_foreach_impl cmake_src_compile
+}
+
+multilib_src_install() {
+ python_foreach_impl cmake_src_install
+}