summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-01-01 21:04:06 -0500
committerMike Gilbert <floppym@gentoo.org>2018-01-01 21:04:20 -0500
commitcf0d5030678f66888119fd14adba0aaed24fdb0f (patch)
tree5d915edfb5a859c48b63e9335d11789de3208b1c /sys-libs
parentdev-util/bcc: version bump to 0.5.0_p20171230 (diff)
downloadgentoo-cf0d5030678f66888119fd14adba0aaed24fdb0f.tar.gz
gentoo-cf0d5030678f66888119fd14adba0aaed24fdb0f.tar.bz2
gentoo-cf0d5030678f66888119fd14adba0aaed24fdb0f.zip
sys-libs/libcap: declare BUILD_CC as local
This prevents multilib CFLAGS from spilling over. This should probably be fixed in multilib.eclass eventually. Package-Manager: Portage-2.3.19_p3, Repoman-2.3.6_p37
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap/libcap-2.24-r2.ebuild5
-rw-r--r--sys-libs/libcap/libcap-2.25.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sys-libs/libcap/libcap-2.24-r2.ebuild b/sys-libs/libcap/libcap-2.24-r2.ebuild
index 5575faa355ce..56d79e96f0e5 100644
--- a/sys-libs/libcap/libcap-2.24-r2.ebuild
+++ b/sys-libs/libcap/libcap-2.24-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="4"
@@ -47,8 +47,9 @@ multilib_src_configure() {
}
multilib_src_compile() {
- tc-export_build_env BUILD_CC
tc-export AR CC RANLIB
+ local BUILD_CC
+ tc-export_build_env BUILD_CC
default
}
diff --git a/sys-libs/libcap/libcap-2.25.ebuild b/sys-libs/libcap/libcap-2.25.ebuild
index feb60b9a4b62..81fb56032a2e 100644
--- a/sys-libs/libcap/libcap-2.25.ebuild
+++ b/sys-libs/libcap/libcap-2.25.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -52,8 +52,9 @@ multilib_src_configure() {
}
multilib_src_compile() {
- tc-export_build_env BUILD_CC
tc-export AR CC RANLIB
+ local BUILD_CC
+ tc-export_build_env BUILD_CC
default
}