summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-30 11:37:29 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-30 11:57:49 +0100
commitd3c429aa0e4525f2f65974f1c80a159cdb1c4eee (patch)
tree139d62b3a0c6a3096e581638d7bd23f47ef2c74d /sys-libs
parentsci-misc/boinc: restore ~arm64 (diff)
downloadgentoo-d3c429aa0e4525f2f65974f1c80a159cdb1c4eee.tar.gz
gentoo-d3c429aa0e4525f2f65974f1c80a159cdb1c4eee.tar.bz2
gentoo-d3c429aa0e4525f2f65974f1c80a159cdb1c4eee.zip
sys-libs/e2fsprogs-libs: Bump to version 1.46.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/e2fsprogs-libs/Manifest1
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.46.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-libs/e2fsprogs-libs/Manifest b/sys-libs/e2fsprogs-libs/Manifest
index cada311694c2..c355da4b53cd 100644
--- a/sys-libs/e2fsprogs-libs/Manifest
+++ b/sys-libs/e2fsprogs-libs/Manifest
@@ -1,2 +1,3 @@
DIST e2fsprogs-1.45.6.tar.xz 5572144 BLAKE2B 24a44d27a02a1fa178083d5ee6034b20fedcac9faf7cf7f5cfcd4e4cee6d38775bc78949b9b00823cbbdacfab783e8e1e739579b9a7236c5425f51b27600743b SHA512 f3abfb6fe7ef632bb81152e2127d601cadd3fa93162178576a1d5ed82c2286627184b207b85a5b2a1793db0addf0885dfc3b9523bb340443224caf9c6d613b84
DIST e2fsprogs-1.45.7.tar.xz 5570052 BLAKE2B 237ef068c3899641b5eb908cc302c8c6b454e337bce2de95fc96b9a078a003db0c44bd34391063cc2f30a95dcce57950fe900f59ae7d273786c657b7c190b341 SHA512 fcbd66af7b87f2bdec562ddd59c8c5fbd60f32fdd582a5c9d21cb6cfea642d2cdca57b6c29124309798528b2d9ceadf770928a6698f75dc88a47701286128763
+DIST e2fsprogs-1.46.0.tar.xz 7007144 BLAKE2B d902028a0e538a62428e18e3c2a0a917a73351afc7d8eec804ddac459a1b8c2e11d104201235fb64170acc78942d2c9d5a45039f770cf5ce537cdba18cd559e6 SHA512 c865360e532da42264200934229aa9cfc88c3342fc4e206e82d1fe2a908b0fd3b58f2e9a4796f2ecdeafe1ace9f9ee444ea5b2e3efd488cb934f9a22af6a8f7e
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.46.0.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.46.0.ebuild
new file mode 100644
index 000000000000..41da9ca3221d
--- /dev/null
+++ b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.46.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs multilib-minimal usr-ldscript
+
+MY_PN=${PN%-libs}
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="e2fsprogs libraries (common error and subsystem)"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="!sys-libs/com_err
+ !sys-libs/ss
+ !<sys-fs/e2fsprogs-1.41.8"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
+)
+
+src_prepare() {
+ default
+
+ cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-elf-shlibs
+ $(tc-has-tls || echo --disable-tls)
+ --disable-e2initrd-helper
+ --disable-fsck
+ )
+
+ # we use blkid/uuid from util-linux now
+ if use kernel_linux ; then
+ export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
+ myconf+=( --disable-lib{blkid,uuid} )
+ fi
+
+ ac_cv_path_LDCONFIG=: \
+ ECONF_SOURCE="${S}" \
+ CC="$(tc-getCC)" \
+ BUILD_CC="$(tc-getBUILD_CC)" \
+ BUILD_LD="$(tc-getBUILD_LD)" \
+ econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake -C lib/et V=1
+
+ emake -C lib/ss V=1
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ emake -C lib/et V=1 check
+
+ emake -C lib/ss V=1 check
+ fi
+}
+
+multilib_src_install() {
+ emake -C lib/et V=1 DESTDIR="${D}" install
+
+ emake -C lib/ss V=1 DESTDIR="${D}" install
+
+ # We call "gen_usr_ldscript -a" to ensure libs are present in /lib to support
+ # split /usr (e.g. "e2fsck" from sys-fs/e2fsprogs is installed in /sbin and
+ # links to libcom_err.so).
+ gen_usr_ldscript -a com_err ss $(usex kernel_linux '' 'uuid blkid')
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+}
+
+multilib_src_install_all() {
+ # Package installs same header twice -- use symlink instead
+ dosym et/com_err.h /usr/include/com_err.h
+
+ einstalldocs
+}